<!DOCTYPE html><!-- HTML 5 -->
<html lang="fr-FR">

<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://blog.seboss666.info/xmlrpc.php" />

<!-- JM Twitter Cards by Julien Maury 10.0.1 -->
<meta name="twitter:card" content="summary">
<meta name="twitter:creator" content="@Seboss666">
<meta name="twitter:site" content="@Seboss666">
<meta name="twitter:title" content="Programmation défensive en bash">
<meta name="twitter:description" content="Nouvelle traduction aujourd&#039;hui, d&#039;un article qui risque sans prévenir de disparaître. La programmation défensive consiste à structurer son code pour limiter au strict minimum les surfaces d&#039;attaq">
<meta name="twitter:image" content="https://blog.seboss666.info/wp-content/uploads/2020/04/defensive_programming.jpg">
<!-- /JM Twitter Cards by Julien Maury 10.0.1 -->
<title>Programmation défensive en bash &#8211; Le blog de Seboss666</title>
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Le blog de Seboss666 &raquo; Flux" href="https://blog.seboss666.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="Le blog de Seboss666 &raquo; Flux des commentaires" href="https://blog.seboss666.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Le blog de Seboss666 &raquo; Programmation défensive en bash Flux des commentaires" href="https://blog.seboss666.info/2020/04/programmation-defensive-en-bash/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.seboss666.info\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='crayon-css'  href='https://blog.seboss666.info/wp-content/plugins/crayon-syntax-highlighter/css/min/crayon.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='crayon-theme-monokai-css'  href='https://blog.seboss666.info/wp-content/plugins/crayon-syntax-highlighter/themes/monokai/monokai.css' type='text/css' media='all' />
<link rel='stylesheet' id='crayon-font-monaco-css'  href='https://blog.seboss666.info/wp-content/plugins/crayon-syntax-highlighter/fonts/monaco.css' type='text/css' media='all' />
<link rel='stylesheet' id='momentous-custom-fonts-css'  href='https://blog.seboss666.info/wp-content/themes/momentous-lite/css/custom-fonts.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://blog.seboss666.info/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='wtr-css-css'  href='https://blog.seboss666.info/wp-content/plugins/worth-the-read/css/wtr.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-font-awesome-css'  href='https://blog.seboss666.info/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.0.6/css/fontawesome-all.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-frontend-css-css'  href='https://blog.seboss666.info/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-user-content-css-css'  href='https://blog.seboss666.info/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-user-content.css' type='text/css' media='all' />
<link rel='stylesheet' id='momentous-lite-css'  href='https://blog.seboss666.info/wp-content/themes/momentous-lite/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://blog.seboss666.info/wp-content/themes/momentous-custom/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='momentous-lite-stylesheet-css'  href='https://blog.seboss666.info/wp-content/themes/momentous-custom/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://blog.seboss666.info/wp-content/themes/momentous-lite/css/genericons/genericons.css' type='text/css' media='all' />
<link rel='stylesheet' id='themezee-related-posts-css'  href='https://blog.seboss666.info/wp-content/themes/momentous-lite/css/themezee-related-posts.css' type='text/css' media='all' />
<link rel='stylesheet' id='jquery.lightbox.min.css-css'  href='https://blog.seboss666.info/wp-content/plugins/wp-jquery-lightbox/styles/lightbox.min.css' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.seboss666.info/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-includes/js/jquery/jquery-migrate.min.js' defer '></script>
<script type='text/javascript'>
/* <![CDATA[ */
var CrayonSyntaxSettings = {"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"https:\/\/blog.seboss666.info\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};
var CrayonSyntaxStrings = {"copy":"Faites %s pour copier, %s pour coller","minimize":"Click To Expand Code"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-content/plugins/crayon-syntax-highlighter/js/min/crayon.min.js' defer '></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://blog.seboss666.info/wp-content/themes/momentous-lite/js/html5shiv.min.js' defer '></script>
<![endif]-->
<script type='text/javascript' src='https://blog.seboss666.info/wp-content/themes/momentous-lite/js/navigation.js' defer '></script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-includes/js/imagesloaded.min.js' defer '></script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-includes/js/masonry.min.js' defer '></script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-content/themes/momentous-lite/js/masonry-init.js' defer '></script>
<link rel='https://api.w.org/' href='https://blog.seboss666.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.seboss666.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.seboss666.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Déployer un service Consul, mais surtout le sécuriser !' href='https://blog.seboss666.info/2020/04/deployer-un-service-consul-mais-surtout-le-securiser/' />
<meta name="generator" content="WordPress 4.9.14" />
<link rel="canonical" href="https://blog.seboss666.info/2020/04/programmation-defensive-en-bash/" />
<link rel='shortlink' href='https://blog.seboss666.info/?p=2935' />
<link rel="alternate" type="application/json+oembed" href="https://blog.seboss666.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.seboss666.info%2F2020%2F04%2Fprogrammation-defensive-en-bash%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.seboss666.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.seboss666.info%2F2020%2F04%2Fprogrammation-defensive-en-bash%2F&#038;format=xml" />
<!-- Old Post Notifier -->
<style type="text/css">
.ikaz {
    margin-top: 0.5em;
	margin-bottom: 0.5em;
    padding: 1em 1.5em 1em 5.5em;
    border-bottom: 2px solid #fff;
    border-top: 2px solid #fff;
    color:#444;
	background: #fff6bf url(https://blog.seboss666.info/wp-content/plugins/old-post-notifier/ikaz.png) 2.2em center no-repeat; border-color: #ffd324;
}
.ikaz .kapat{ position:relative; float:right; top:-5px; right:-5px; }
.ikaz .kapat img{border:none; background:none;}
.ikaz a  {color: #817134;}
</style>
<!-- Old Post Notifier -->
<style type="text/css">.wtr-time-wrap{ 
	/* wraps the entire label */
	margin: 0 10px;

}
.wtr-time-number{ 
	/* applies only to the number */
	
}</style>            <style>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</style>
            <style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><style type="text/css" title="dynamic-css" class="options-output">.wtr-time-wrap{line-height:16px;color:#CCCCCC;font-size:16px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading .wtr-time-wrap,{opacity: 0;}.ie.wf-loading .wtr-time-wrap,{visibility: hidden;}</style></head>

<body class="post-template-default single single-post postid-2935 single-format-standard">

<a class="skip-link screen-reader-text" href="#content">Skip to content</a>


<div id="wrapper" class="hfeed">

	<div id="header-wrap">

		
			<div id="header-search-wrap">

				<div id="header-search" class="container clearfix">
					
	<form role="search" method="get" class="search-form" action="https://blog.seboss666.info/">
		<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field" placeholder="To search, type and hit enter &hellip;" value="" name="s">
		</label>
		<button type="submit" class="search-submit">
			<span class="genericon-search"></span>
		</button>
	</form>

				</div>

			</div>

		
		<header id="header" class="container clearfix" role="banner">

			<div id="logo">

								
		<p class="site-title"><a href="https://blog.seboss666.info/" rel="home">Le blog de Seboss666</a></p>

					
			<p class="site-description">Les divagations d&#039;un pseudo-geek curieux</p>

		
			</div>

			<div id="header-content" class="clearfix">

									<div class="header-search-icon">
						<span class="genericon-search"></span>
					</div>
				
				
			</div>

		</header>

		<div id="navigation-wrap">

			<div id="navigation" class="container clearfix">

				
						<div id="navi-social-icons" class="social-icons-wrap clearfix">
							<ul id="social-icons-menu" class="menu"><li id="menu-item-1276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1276"><a href="https://twitter.com/Seboss666"><span class="screen-reader-text">Compte Twitter</span></a></li>
<li id="menu-item-1277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1277"><a href="https://youtube.com/user/tocmorpheus/"><span class="screen-reader-text">Chaîne YouTube</span></a></li>
<li id="menu-item-2901" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2901"><a href="https://blog.seboss666.info/feed"><span class="screen-reader-text">RSS</span></a></li>
</ul>						</div>

				

				<nav id="mainnav" class="clearfix" role="navigation">
					<ul id="mainnav-menu" class="main-navigation-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-79"><a href="https://blog.seboss666.info">Accueil</a></li>
<li id="menu-item-3147" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-3147"><a href="https://blog.seboss666.info/category/series/">Séries</a>
<ul class="sub-menu">
	<li id="menu-item-3148" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3148"><a href="https://blog.seboss666.info/category/series/firefox/">Firefox</a></li>
	<li id="menu-item-3152" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3152"><a href="https://blog.seboss666.info/category/series/securisation-serveur/">Sécurisation serveur</a></li>
	<li id="menu-item-3592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3592"><a href="https://blog.seboss666.info/category/series/mr-bricolage/">Voyage au cœur de la bête</a></li>
	<li id="menu-item-3149" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3149"><a href="https://blog.seboss666.info/category/series/liens-en-vrac/">Liens en vrac</a></li>
	<li id="menu-item-3150" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3150"><a href="https://blog.seboss666.info/category/series/migration-linux/">Migration Linux</a></li>
	<li id="menu-item-3591" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3591"><a href="https://blog.seboss666.info/category/series/astuces-diverses/">Astuces diverses</a></li>
	<li id="menu-item-3151" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3151"><a href="https://blog.seboss666.info/category/series/mongodb/">MongoDB</a></li>
	<li id="menu-item-3153" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3153"><a href="https://blog.seboss666.info/category/series/termes-expliques/">Termes expliqués</a></li>
</ul>
</li>
<li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78"><a href="https://blog.seboss666.info/category/astuces/">Astuces</a>
<ul class="sub-menu">
	<li id="menu-item-3146" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3146"><a href="https://blog.seboss666.info/category/astuces/depannage/">Dépannage</a></li>
</ul>
</li>
<li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77"><a href="https://blog.seboss666.info/category/sysadmin/">Sysadmin</a></li>
<li id="menu-item-1366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1366"><a href="https://blog.seboss666.info/category/vulgarisation/">Vulgarisation</a></li>
<li id="menu-item-1120" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1120"><a href="https://blog.seboss666.info/category/web/">Web</a></li>
<li id="menu-item-480" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-480"><a href="https://blog.seboss666.info/category/mobilite/">Mobilité</a></li>
<li id="menu-item-100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-100"><a href="https://blog.seboss666.info/category/humeur/">Humeur</a></li>
<li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-191"><a href="https://blog.seboss666.info/category/projets/">Projets</a>
<ul class="sub-menu">
	<li id="menu-item-2774" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2774"><a href="https://blog.seboss666.info/category/projets/editos/">Editos</a></li>
	<li id="menu-item-4988" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4988"><a href="https://blog.seboss666.info/astuces-diverses-recap/">Astuces diverses, récap</a></li>
</ul>
</li>
<li id="menu-item-80" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80"><a href="https://blog.seboss666.info/category/divers/">Divers</a></li>
<li id="menu-item-2234" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234"><a href="https://blog.seboss666.info/contact/">Contact</a></li>
</ul>				</nav>

			</div>

		</div>

	</div>

	
	<div id="wrap" class="container clearfix">
		
		<section id="content" class="primary" role="main">
		
					
		
	<article id="post-2935" class="post-2935 post type-post status-publish format-standard has-post-thumbnail hentry category-astuces tag-bash tag-clarte tag-defensive tag-pratique tag-programmation tag-qualite tag-securite">
	
		<img width="900" height="300" src="https://blog.seboss666.info/wp-content/uploads/2020/04/defensive_programming-900x300.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://blog.seboss666.info/wp-content/uploads/2020/04/defensive_programming-900x300.jpg 900w, https://blog.seboss666.info/wp-content/uploads/2020/04/defensive_programming-480x160.jpg 480w" sizes="(max-width: 900px) 100vw, 900px" />		
		<h1 class="entry-title post-title">Programmation défensive en bash</h1>		
		<div class="entry-meta postmeta"><span class="meta-date">Posted on <a href="https://blog.seboss666.info/2020/04/programmation-defensive-en-bash/" title="18:30" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-27T18:30:26+00:00">27/04/2020</time></a></span><span class="meta-author"> by <span class="author vcard"><a class="url fn n" href="https://blog.seboss666.info/author/seboss666/" title="Voir tous les articles de Seboss666" rel="author">Seboss666</a></span></span></div>

		<div class="entry clearfix">
			<div id="wtr-content" 
	    	data-bg="transparent" 
	    	data-fg="#0185c1" 
	    	data-width="5" 
	    	data-mute="" 
	    	data-fgopacity="0.80" 
	    	data-mutedopacity="0.5" 
	    	data-placement="top" 
	    	data-placement-offset="0" 
	    	data-content-offset="0" 
	    	data-placement-touch="top" 
		    data-placement-offset-touch="0" 
	    	data-transparent="" 
	    	data-touch="1" 
	    	data-non-touch="1" 
	    	data-comments="" 
	    	data-commentsbg="#4d9cc1" 
	    	data-location="page" 
	    	data-mutedfg="#4d9cc1" 
	    	data-rtl="" 
	    	><div style="text-align: left"><div style="width: 100%;">
        <a target="_blank" title="Twitter" href="https://twitter.com/share?url=https://blog.seboss666.info/2020/04/programmation-defensive-en-bash/&text=Programmation défensive en bash&via=seboss666" rel="nofollow" onclick="javascript:window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=400,width=700');return false;"><img src="/wp-content/uploads/2013/10/sb_twitter_icon.png" alt="Twitter" /></a>
        <a target="_blank" title="Facebook" href="https://www.facebook.com/sharer.php?u=https://blog.seboss666.info/2020/04/programmation-defensive-en-bash/&t=Programmation défensive en bash" rel="nofollow" onclick="javascript:window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=500,width=700');return false;"><img src="/wp-content/uploads/2013/10/sb_facebook_icon.png" alt="Facebook" /></a>
        <a target="_blank" title="Google +" href="https://plus.google.com/share?url=https://blog.seboss666.info/2020/04/programmation-defensive-en-bash/&hl=fr" rel="nofollow" onclick="javascript:window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=450,width=650');return false;"><img src="/wp-content/uploads/2013/10/sb_gplus_icon.png" alt="Google Plus" /></a>
        <a target="_blank" title="Linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://blog.seboss666.info/2020/04/programmation-defensive-en-bash/&title=Programmation défensive en bash" rel="nofollow" onclick="javascript:window.open(this.href, '','menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=450,width=650');return false;"><img src="/wp-content/uploads/2013/10/sb_linkedin_icon.png" alt="Linkedin" /></a>
        <a target="_blank" title="Envoyer par mail" href="mailto:?subject=Programmation défensive en bash&body=https://blog.seboss666.info/2020/04/programmation-defensive-en-bash/" rel="nofollow"><img src="/wp-content/uploads/2013/10/sb_email_icon.png" alt="email" /></a>

 </div></div>
<p style="text-align: justify;">Nouvelle traduction aujourd&rsquo;hui, d&rsquo;un article qui risque sans prévenir de disparaître. La <a href="http://kfirlavi.herokuapp.com/blog/2012/11/14/defensive-bash-programming/" target="_blank" rel="noopener">programmation défensive</a> consiste à structurer son code pour limiter au strict minimum les surfaces d&rsquo;attaques. Le JDN a un article <a href="http://www.journaldunet.com/developpeur/tutoriel/theo/070831-programmation-defensive.shtml" target="_blank" rel="noopener">qui résume bien</a> des concepts, mais ici, on va s&rsquo;attarder sur les scripts Bash. En effet, comme avec PHP on peut vite faire de la merde, et il est préférable de suivre certaines pratiques pour que leur qualité ne soit pas trop catastrophique quand il seront réutilisés ailleurs. Je ne les suis pas toutes, mais j&rsquo;ai trouvé utile de les partager avec vous.</p>
<p style="text-align: justify;"><span id="more-2935"></span></p>
<h3 style="text-align: justify;">Variables globales immutables</h3>
<ul style="text-align: justify;">
<li>Essayez de limiter le nombre de variables globales</li>
<li>Nommage en majuscules</li>
<li>déclarations en lecture seule</li>
<li>Utilisez des variables globales pour remplacer les cryptiques $1, $0, etc</li>
<li>Les globales que j’utilise pratiquement systématiquement dans mes scripts :</li>
</ul>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f17949246316" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
readonly PROGNAME=$(basename $0)
readonly PROGDIR=$(readlink -m $(dirname $0))
readonly ARGS="$@"</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f17949246316-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f17949246316-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f17949246316-3">3</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f17949246316-1"><span class="crayon-e">readonly </span><span class="crayon-v">PROGNAME</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-sy">(</span><span class="crayon-r">basename</span><span class="crayon-h"> </span><span class="crayon-sy">$</span><span class="crayon-cn">0</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f17949246316-2"><span class="crayon-e">readonly </span><span class="crayon-v">PROGDIR</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-sy">(</span><span class="crayon-v">readlink</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">m</span><span class="crayon-h"> </span><span class="crayon-sy">$</span><span class="crayon-sy">(</span><span class="crayon-r">dirname</span><span class="crayon-h"> </span><span class="crayon-sy">$</span><span class="crayon-cn">0</span><span class="crayon-sy">)</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-5eb04c2809f17949246316-3"><span class="crayon-e">readonly </span><span class="crayon-v">ARGS</span><span class="crayon-o">=</span><span class="crayon-s">"$@"</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0002 seconds] -->
<p></p>
<h3 style="text-align: justify;">Tout est local</h3>
<p style="text-align: justify;">Toutes les variables devraient être locales.</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f20787195533" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
change_owner_of_file() {
  local filename=$1
  local user=$2
  local group=$3

  chown $user:$group $filename
}


change_owner_of_files() {
  local user=$1; shift
  local group=$1; shift
  local files=$@
  local i

  for i in $files
  do
    chown $user:$group $i
  done
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f20787195533-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f20787195533-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f20787195533-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f20787195533-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f20787195533-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f20787195533-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f20787195533-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f20787195533-8">8</div><div class="crayon-num" data-line="crayon-5eb04c2809f20787195533-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f20787195533-10">10</div><div class="crayon-num" data-line="crayon-5eb04c2809f20787195533-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f20787195533-12">12</div><div class="crayon-num" data-line="crayon-5eb04c2809f20787195533-13">13</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f20787195533-14">14</div><div class="crayon-num" data-line="crayon-5eb04c2809f20787195533-15">15</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f20787195533-16">16</div><div class="crayon-num" data-line="crayon-5eb04c2809f20787195533-17">17</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f20787195533-18">18</div><div class="crayon-num" data-line="crayon-5eb04c2809f20787195533-19">19</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f20787195533-20">20</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f20787195533-1"><span class="crayon-e">change_owner_of_file</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f20787195533-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">filename</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line" id="crayon-5eb04c2809f20787195533-3"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">user</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">2</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f20787195533-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">group</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">3</span></div><div class="crayon-line" id="crayon-5eb04c2809f20787195533-5">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f20787195533-6"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">chown</span><span class="crayon-h"> </span><span class="crayon-v">$user</span><span class="crayon-o">:</span><span class="crayon-v">$group</span><span class="crayon-h"> </span><span class="crayon-v">$filename</span></div><div class="crayon-line" id="crayon-5eb04c2809f20787195533-7"><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f20787195533-8">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f20787195533-9">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f20787195533-10"><span class="crayon-e">change_owner_of_files</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line" id="crayon-5eb04c2809f20787195533-11"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">user</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span><span class="crayon-sy">;</span><span class="crayon-h"> </span><span class="crayon-e">shift</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f20787195533-12"><span class="crayon-e">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">group</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span><span class="crayon-sy">;</span><span class="crayon-h"> </span><span class="crayon-e">shift</span></div><div class="crayon-line" id="crayon-5eb04c2809f20787195533-13"><span class="crayon-e">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">files</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-sy">@</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f20787195533-14"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">local</span><span class="crayon-h"> </span><span class="crayon-i">i</span></div><div class="crayon-line" id="crayon-5eb04c2809f20787195533-15">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f20787195533-16"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-st">for</span><span class="crayon-h"> </span><span class="crayon-i">i</span><span class="crayon-h"> </span><span class="crayon-st">in</span><span class="crayon-h"> </span><span class="crayon-v">$files</span></div><div class="crayon-line" id="crayon-5eb04c2809f20787195533-17"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-st">do</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f20787195533-18"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-r">chown</span><span class="crayon-h"> </span><span class="crayon-v">$user</span><span class="crayon-o">:</span><span class="crayon-v">$group</span><span class="crayon-h"> </span><span class="crayon-v">$i</span></div><div class="crayon-line" id="crayon-5eb04c2809f20787195533-19"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-st">done</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f20787195533-20"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0005 seconds] -->
<p></p>
<ul style="text-align: justify;">
<li>des paramètres « auto-documentés »</li>
<li>Habituellement pour les boucles ont utilise « i », il est vital de la déclarer comme locale</li>
<li>les variables locales ne fonctionnent pas dans un contexte global :</li>
</ul>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f22937209791" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
kfir@goofy ~ $ local a
bash: local: can only be used in a function</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f22937209791-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f22937209791-2">2</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f22937209791-1"><span class="crayon-v">kfir</span><span class="crayon-sy">@</span><span class="crayon-v">goofy</span><span class="crayon-h"> </span><span class="crayon-o">~</span><span class="crayon-h"> </span><span class="crayon-sy">$</span><span class="crayon-h"> </span><span class="crayon-i">local</span><span class="crayon-h"> </span><span class="crayon-i">a</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f22937209791-2"><span class="crayon-r">bash</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">local</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-e">can </span><span class="crayon-e">only </span><span class="crayon-e">be </span><span class="crayon-e">used </span><span class="crayon-st">in</span><span class="crayon-h"> </span><span class="crayon-i">a</span><span class="crayon-h"> </span><span class="crayon-t">function</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0002 seconds] -->
<p></p>
<h3 style="text-align: justify;">main()</h3>
<ul style="text-align: justify;">
<li>Permet de conserver toutes les variables comme locales</li>
<li>Intuitif pour la programmation fonctionnelle</li>
<li>La seule commande globale dans le code est : main</li>
</ul>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f24627267888" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
main() {
  local files="/tmp/a /tmp/b"
  local i

  for i in $files
    do
      change_owner_of_file kfir users $i
    done
}
main</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f24627267888-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f24627267888-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f24627267888-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f24627267888-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f24627267888-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f24627267888-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f24627267888-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f24627267888-8">8</div><div class="crayon-num" data-line="crayon-5eb04c2809f24627267888-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f24627267888-10">10</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f24627267888-1"><span class="crayon-e">main</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f24627267888-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">files</span><span class="crayon-o">=</span><span class="crayon-s">"/tmp/a /tmp/b"</span></div><div class="crayon-line" id="crayon-5eb04c2809f24627267888-3"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">local</span><span class="crayon-h"> </span><span class="crayon-i">i</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f24627267888-4">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f24627267888-5"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-st">for</span><span class="crayon-h"> </span><span class="crayon-i">i</span><span class="crayon-h"> </span><span class="crayon-st">in</span><span class="crayon-h"> </span><span class="crayon-v">$files</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f24627267888-6"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-st">do</span></div><div class="crayon-line" id="crayon-5eb04c2809f24627267888-7"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-e">change_owner_of_file </span><span class="crayon-e">kfir </span><span class="crayon-i">users</span><span class="crayon-h"> </span><span class="crayon-v">$i</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f24627267888-8"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-st">done</span></div><div class="crayon-line" id="crayon-5eb04c2809f24627267888-9"><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f24627267888-10"><span class="crayon-v">main</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0002 seconds] -->
<p></p>
<h3 style="text-align: justify;">Tout est une fonction</h3>
<ul style="text-align: justify;">
<li>Le seul code qui tourne globalement est
<ul>
<li>Les déclarations globales qui sont immutables</li>
<li>main</li>
</ul>
</li>
<li>Permet de garder un code propre</li>
<li>Les procédures sont plus descriptives</li>
</ul>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f26977355149" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
main() {
local files=$(ls /tmp | grep pid | grep -v daemon)
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f26977355149-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f26977355149-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f26977355149-3">3</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f26977355149-1"><span class="crayon-e">main</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f26977355149-2"><span class="crayon-e">local </span><span class="crayon-v">files</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-sy">(</span><span class="crayon-r">ls</span><span class="crayon-h"> </span><span class="crayon-o">/</span><span class="crayon-v">tmp</span><span class="crayon-h"> </span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-v">pid</span><span class="crayon-h"> </span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">v</span><span class="crayon-h"> </span><span class="crayon-v">daemon</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-5eb04c2809f26977355149-3"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0002 seconds] -->
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f28203797342" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
temporary_files() {
  local dir=$1

  ls $dir \
    | grep pid \
    | grep -v daemon
}

main() {
  local files=$(temporary_files /tmp)
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f28203797342-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f28203797342-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f28203797342-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f28203797342-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f28203797342-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f28203797342-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f28203797342-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f28203797342-8">8</div><div class="crayon-num" data-line="crayon-5eb04c2809f28203797342-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f28203797342-10">10</div><div class="crayon-num" data-line="crayon-5eb04c2809f28203797342-11">11</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f28203797342-1"><span class="crayon-e">temporary_files</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f28203797342-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">dir</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line" id="crayon-5eb04c2809f28203797342-3">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f28203797342-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">ls</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f28203797342-5"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-i">pid</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f28203797342-6"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">v</span><span class="crayon-h"> </span><span class="crayon-i">daemon</span></div><div class="crayon-line" id="crayon-5eb04c2809f28203797342-7"><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f28203797342-8">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f28203797342-9"><span class="crayon-e">main</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f28203797342-10"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">files</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-sy">(</span><span class="crayon-v">temporary_files</span><span class="crayon-h"> </span><span class="crayon-o">/</span><span class="crayon-v">tmp</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-5eb04c2809f28203797342-11"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0003 seconds] -->
<p></p>
<ul style="text-align: justify;">
<li><em>Le deuxième exemple est bien meilleur</em>. Rechercher des fichiers est le problème de temporary_files() et pas celui de main(). Le code est également mieux « testable », via un test unitaire sur temporary_files().</li>
<li>Si vous testez la première version, vous mélangez la logique de recherche du reste de main.</li>
</ul>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f29639592272" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
test_temporary_files() {
  local dir=/tmp

  touch $dir/a-pid1232.tmp
  touch $dir/a-pid1232-daemon.tmp

  returns "$dir/a-pid1232.tmp" temporary_files $dir

  touch $dir/b-pid1534.tmp

  returns "$dir/a-pid1232.tmp $dir/b-pid1534.tmp" temporary_files $dir
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f29639592272-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f29639592272-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f29639592272-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f29639592272-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f29639592272-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f29639592272-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f29639592272-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f29639592272-8">8</div><div class="crayon-num" data-line="crayon-5eb04c2809f29639592272-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f29639592272-10">10</div><div class="crayon-num" data-line="crayon-5eb04c2809f29639592272-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f29639592272-12">12</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f29639592272-1"><span class="crayon-e">test_temporary_files</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f29639592272-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">dir</span><span class="crayon-o">=</span><span class="crayon-o">/</span><span class="crayon-e">tmp</span></div><div class="crayon-line" id="crayon-5eb04c2809f29639592272-3">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f29639592272-4"><span class="crayon-e">&nbsp;&nbsp;</span><span class="crayon-r">touch</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-o">/</span><span class="crayon-v">a</span><span class="crayon-o">-</span><span class="crayon-v">pid1232</span><span class="crayon-e">.tmp</span></div><div class="crayon-line" id="crayon-5eb04c2809f29639592272-5"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">touch</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-o">/</span><span class="crayon-v">a</span><span class="crayon-o">-</span><span class="crayon-v">pid1232</span><span class="crayon-o">-</span><span class="crayon-v">daemon</span><span class="crayon-e">.tmp</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f29639592272-6">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f29639592272-7"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">returns</span><span class="crayon-h"> </span><span class="crayon-s">"$dir/a-pid1232.tmp"</span><span class="crayon-h"> </span><span class="crayon-v">temporary</span><span class="crayon-sy">_</span>files<span class="crayon-h"> </span><span class="crayon-v">$dir</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f29639592272-8">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f29639592272-9"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">touch</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-o">/</span><span class="crayon-v">b</span><span class="crayon-o">-</span><span class="crayon-v">pid1534</span><span class="crayon-e">.tmp</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f29639592272-10">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f29639592272-11"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">returns</span><span class="crayon-h"> </span><span class="crayon-s">"$dir/a-pid1232.tmp $dir/b-pid1534.tmp"</span><span class="crayon-h"> </span><span class="crayon-v">temporary</span><span class="crayon-sy">_</span>files<span class="crayon-h"> </span><span class="crayon-v">$dir</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f29639592272-12"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0004 seconds] -->
<p></p>
<p style="text-align: justify;">Comme vous le voyez, ce test ne concerne pas main().</p>
<h3 style="text-align: justify;">Des fonctions de debug</h3>
<ul style="text-align: justify;">
<li>Lancez le programme avec le drapeau -x :</li>
</ul>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f2b725165080" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
bash -x my_prog.sh</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f2b725165080-1">1</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f2b725165080-1"><span class="crayon-r">bash</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">x</span><span class="crayon-h"> </span><span class="crayon-v">my_prog</span><span class="crayon-e">.sh</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0001 seconds] -->
<p></p>
<ul style="text-align: justify;">
<li>Débuggez une portion du code en utilisant set -x et set +x, ce qui va afficher les messages de débug pour le code entouré des commandes.</li>
</ul>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f2d659267493" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
temporary_files() {
  local dir=$1

  set -x
  ls $dir \
    | grep pid \
    | grep -v daemon
  set +x
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f2d659267493-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f2d659267493-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f2d659267493-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f2d659267493-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f2d659267493-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f2d659267493-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f2d659267493-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f2d659267493-8">8</div><div class="crayon-num" data-line="crayon-5eb04c2809f2d659267493-9">9</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f2d659267493-1"><span class="crayon-e">temporary_files</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f2d659267493-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">dir</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line" id="crayon-5eb04c2809f2d659267493-3">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f2d659267493-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">set</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">x</span></div><div class="crayon-line" id="crayon-5eb04c2809f2d659267493-5"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">ls</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f2d659267493-6"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-i">pid</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f2d659267493-7"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">v</span><span class="crayon-h"> </span><span class="crayon-e">daemon</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f2d659267493-8"><span class="crayon-e">&nbsp;&nbsp;</span><span class="crayon-v">set</span><span class="crayon-h"> </span><span class="crayon-o">+</span><span class="crayon-i">x</span></div><div class="crayon-line" id="crayon-5eb04c2809f2d659267493-9"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0003 seconds] -->
<p></p>
<ul style="text-align: justify;">
<li>Affichez le nom de la fonction et ses arguments :</li>
</ul>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f2e947380659" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
temporary_files() {
  echo $FUNCNAME $@
  local dir=$1

  ls $dir \
    | grep pid \
    | grep -v daemon
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f2e947380659-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f2e947380659-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f2e947380659-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f2e947380659-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f2e947380659-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f2e947380659-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f2e947380659-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f2e947380659-8">8</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f2e947380659-1"><span class="crayon-e">temporary_files</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f2e947380659-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">echo</span><span class="crayon-h"> </span><span class="crayon-v">$FUNCNAME</span><span class="crayon-h"> </span><span class="crayon-sy">$</span><span class="crayon-sy">@</span></div><div class="crayon-line" id="crayon-5eb04c2809f2e947380659-3"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">dir</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f2e947380659-4">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f2e947380659-5"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">ls</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f2e947380659-6"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-i">pid</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f2e947380659-7"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">v</span><span class="crayon-h"> </span><span class="crayon-i">daemon</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f2e947380659-8"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0002 seconds] -->
<p></p>
<p style="text-align: justify;">Donc, en appelant la fonction :</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f30834872274" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
temporary_files /tmp</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f30834872274-1">1</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f30834872274-1"><span class="crayon-v">temporary_files</span><span class="crayon-h"> </span><span class="crayon-o">/</span><span class="crayon-v">tmp</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0001 seconds] -->
<p></p>
<p style="text-align: justify;">affichera sur la sortie standard :</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f31846950078" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
temporary_files /tmp</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f31846950078-1">1</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f31846950078-1"><span class="crayon-v">temporary_files</span><span class="crayon-h"> </span><span class="crayon-o">/</span><span class="crayon-v">tmp</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0001 seconds] -->
<p></p>
<h3 style="text-align: justify;">Clarté du code</h3>
<p style="text-align: justify;">Qu&rsquo;est-ce que fait ce code ?</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f33655268757" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
main() {
  local dir=/tmp

  [[ -z $dir ]] \
    &amp;&amp; do_something...

  [[ -n $dir ]] \
    &amp;&amp; do_something...

  [[ -f $dir ]] \
    &amp;&amp; do_something...

  [[ -d $dir ]] \
    &amp;&amp; do_something...
}
main</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f33655268757-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f33655268757-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f33655268757-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f33655268757-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f33655268757-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f33655268757-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f33655268757-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f33655268757-8">8</div><div class="crayon-num" data-line="crayon-5eb04c2809f33655268757-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f33655268757-10">10</div><div class="crayon-num" data-line="crayon-5eb04c2809f33655268757-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f33655268757-12">12</div><div class="crayon-num" data-line="crayon-5eb04c2809f33655268757-13">13</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f33655268757-14">14</div><div class="crayon-num" data-line="crayon-5eb04c2809f33655268757-15">15</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f33655268757-16">16</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f33655268757-1"><span class="crayon-e">main</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f33655268757-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">dir</span><span class="crayon-o">=</span><span class="crayon-o">/</span><span class="crayon-i">tmp</span></div><div class="crayon-line" id="crayon-5eb04c2809f33655268757-3">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f33655268757-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-sy">[</span><span class="crayon-sy">[</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">z</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">]</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f33655268757-5"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">&amp;&amp;</span><span class="crayon-h"> </span><span class="crayon-v">do_something</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f33655268757-6">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f33655268757-7"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-sy">[</span><span class="crayon-sy">[</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">n</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">]</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f33655268757-8"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">&amp;&amp;</span><span class="crayon-h"> </span><span class="crayon-v">do_something</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span></div><div class="crayon-line" id="crayon-5eb04c2809f33655268757-9">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f33655268757-10"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-sy">[</span><span class="crayon-sy">[</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">f</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">]</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f33655268757-11"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">&amp;&amp;</span><span class="crayon-h"> </span><span class="crayon-v">do_something</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f33655268757-12">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f33655268757-13"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-sy">[</span><span class="crayon-sy">[</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">d</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">]</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f33655268757-14"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">&amp;&amp;</span><span class="crayon-h"> </span><span class="crayon-v">do_something</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span></div><div class="crayon-line" id="crayon-5eb04c2809f33655268757-15"><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f33655268757-16"><span class="crayon-v">main</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0005 seconds] -->
<p></p>
<p style="text-align: justify;">Laissez votre code parler :</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f34794061637" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
is_empty() {
  local var=$1

  [[ -z $var ]]
}

is_not_empty() {
  local var=$1

  [[ -n $var ]]
}

is_file() {
  local file=$1

  [[ -f $file ]]
}

is_dir() {
  local dir=$1

  [[ -d $dir ]]
}

main() {
  local dir=/tmp

  is_empty $dir \
    &amp;&amp; do_something...

  is_not_empty $dir \
    &amp;&amp; do_something...

  is_file $dir \
    &amp;&amp; do_something...

  is_dir $dir \
    &amp;&amp; do_something...
}
main</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-8">8</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-10">10</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-12">12</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-13">13</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-14">14</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-15">15</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-16">16</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-17">17</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-18">18</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-19">19</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-20">20</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-21">21</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-22">22</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-23">23</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-24">24</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-25">25</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-26">26</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-27">27</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-28">28</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-29">29</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-30">30</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-31">31</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-32">32</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-33">33</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-34">34</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-35">35</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-36">36</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-37">37</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-38">38</div><div class="crayon-num" data-line="crayon-5eb04c2809f34794061637-39">39</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f34794061637-40">40</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f34794061637-1"><span class="crayon-e">is_empty</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-t">var</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-3">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-sy">[</span><span class="crayon-sy">[</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">z</span><span class="crayon-h"> </span><span class="crayon-v">$var</span><span class="crayon-h"> </span><span class="crayon-sy">]</span><span class="crayon-sy">]</span></div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-5"><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-6">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-7"><span class="crayon-e">is_not_empty</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-8"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-t">var</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-9">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-10"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-sy">[</span><span class="crayon-sy">[</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">n</span><span class="crayon-h"> </span><span class="crayon-v">$var</span><span class="crayon-h"> </span><span class="crayon-sy">]</span><span class="crayon-sy">]</span></div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-11"><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-12">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-13"><span class="crayon-e">is_file</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-14"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-r">file</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-15">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-16"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-sy">[</span><span class="crayon-sy">[</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">f</span><span class="crayon-h"> </span><span class="crayon-v">$file</span><span class="crayon-h"> </span><span class="crayon-sy">]</span><span class="crayon-sy">]</span></div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-17"><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-18">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-19"><span class="crayon-e">is_dir</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-20"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">dir</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-21">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-22"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-sy">[</span><span class="crayon-sy">[</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">d</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">]</span><span class="crayon-sy">]</span></div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-23"><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-24">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-25"><span class="crayon-e">main</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-26"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">dir</span><span class="crayon-o">=</span><span class="crayon-o">/</span><span class="crayon-e">tmp</span></div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-27">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-28"><span class="crayon-e">&nbsp;&nbsp;</span><span class="crayon-v">is</span><span class="crayon-sy">_</span>empty<span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-29"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">&amp;&amp;</span><span class="crayon-h"> </span><span class="crayon-v">do_something</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-30">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-31"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">is_not</span><span class="crayon-sy">_</span>empty<span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-32"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">&amp;&amp;</span><span class="crayon-h"> </span><span class="crayon-v">do_something</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span></div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-33">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-34"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">is</span><span class="crayon-sy">_</span>file<span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-35"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">&amp;&amp;</span><span class="crayon-h"> </span><span class="crayon-v">do_something</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-36">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-37"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">is</span><span class="crayon-sy">_</span>dir<span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-38"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">&amp;&amp;</span><span class="crayon-h"> </span><span class="crayon-v">do_something</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span><span class="crayon-sy">.</span></div><div class="crayon-line" id="crayon-5eb04c2809f34794061637-39"><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f34794061637-40"><span class="crayon-v">main</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0008 seconds] -->
<p></p>
<h3 style="text-align: justify;">Chaque ligne fait une seule chose</h3>
<ul style="text-align: justify;">
<li>Sectionnez vos commandes avec des antislash <code></code>. Par exemple :</li>
</ul>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f36241895718" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
temporary_files() {
  local dir=$1

  ls $dir | grep pid | grep -v daemon
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f36241895718-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f36241895718-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f36241895718-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f36241895718-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f36241895718-5">5</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f36241895718-1"><span class="crayon-e">temporary_files</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f36241895718-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">dir</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line" id="crayon-5eb04c2809f36241895718-3">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f36241895718-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">ls</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-v">pid</span><span class="crayon-h"> </span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">v</span><span class="crayon-h"> </span><span class="crayon-i">daemon</span></div><div class="crayon-line" id="crayon-5eb04c2809f36241895718-5"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0002 seconds] -->
<p></p>
<p style="text-align: justify;">Peut être écrit plus clairement :</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f38693346584" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
temporary_files() {
  local dir=$1

  ls $dir \
    | grep pid \
    | grep -v daemon
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f38693346584-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f38693346584-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f38693346584-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f38693346584-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f38693346584-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f38693346584-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f38693346584-7">7</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f38693346584-1"><span class="crayon-e">temporary_files</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f38693346584-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">dir</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line" id="crayon-5eb04c2809f38693346584-3">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f38693346584-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">ls</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f38693346584-5"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-i">pid</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f38693346584-6"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">v</span><span class="crayon-h"> </span><span class="crayon-i">daemon</span></div><div class="crayon-line" id="crayon-5eb04c2809f38693346584-7"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0003 seconds] -->
<p></p>
<ul style="text-align: justify;">
<li>Les symboles doivent être en début de ligne. Mauvais exemple de symboles à la fin :</li>
</ul>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f39643210574" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
temporary_files() {
  local dir=$1

  ls $dir | \
    grep pid | \
    grep -v daemon
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f39643210574-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f39643210574-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f39643210574-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f39643210574-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f39643210574-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f39643210574-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f39643210574-7">7</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f39643210574-1"><span class="crayon-e">temporary_files</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f39643210574-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">dir</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line" id="crayon-5eb04c2809f39643210574-3">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f39643210574-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">ls</span><span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f39643210574-5"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-v">pid</span><span class="crayon-h"> </span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f39643210574-6"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">v</span><span class="crayon-h"> </span><span class="crayon-i">daemon</span></div><div class="crayon-line" id="crayon-5eb04c2809f39643210574-7"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0003 seconds] -->
<p></p>
<p style="text-align: justify;">Bon exemple où l&rsquo;on voit clairement la connexion entre les les lignes et les symboles :</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f3b929152127" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
print_dir_if_not_empty() {
  local dir=$1

  is_empty $dir \
    &amp;&amp; echo "dir is empty" \
    || echo "dir=$dir"
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f3b929152127-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3b929152127-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f3b929152127-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3b929152127-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f3b929152127-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3b929152127-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f3b929152127-7">7</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f3b929152127-1"><span class="crayon-e">print_dir_if_not_empty</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3b929152127-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">dir</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line" id="crayon-5eb04c2809f3b929152127-3">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3b929152127-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">is</span><span class="crayon-sy">_</span>empty<span class="crayon-h"> </span><span class="crayon-v">$dir</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f3b929152127-5"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">&amp;&amp;</span><span class="crayon-h"> </span><span class="crayon-r">echo</span><span class="crayon-h"> </span><span class="crayon-s">"dir is empty"</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3b929152127-6"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">||</span><span class="crayon-h"> </span><span class="crayon-r">echo</span><span class="crayon-h"> </span><span class="crayon-s">"dir=$dir"</span></div><div class="crayon-line" id="crayon-5eb04c2809f3b929152127-7"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0002 seconds] -->
<p></p>
<h3 style="text-align: justify;">Afficher l&rsquo;usage</h3>
<p style="text-align: justify;">Ne faites pas ça :</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f3c700907101" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
echo "this prog does:..."
echo "flags:"
echo "-h print help"</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f3c700907101-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3c700907101-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f3c700907101-3">3</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f3c700907101-1"><span class="crayon-r">echo</span><span class="crayon-h"> </span><span class="crayon-s">"this prog does:..."</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3c700907101-2"><span class="crayon-r">echo</span><span class="crayon-h"> </span><span class="crayon-s">"flags:"</span></div><div class="crayon-line" id="crayon-5eb04c2809f3c700907101-3"><span class="crayon-r">echo</span><span class="crayon-h"> </span><span class="crayon-s">"-h print help"</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0001 seconds] -->
<p></p>
<p style="text-align: justify;">Ça devrait être une fonction :</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f3e434070305" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
usage() {
  echo "this prog does:..."
  echo "flags:"
  echo "-h print help"
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f3e434070305-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3e434070305-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f3e434070305-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3e434070305-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f3e434070305-5">5</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f3e434070305-1"><span class="crayon-e">usage</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3e434070305-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">echo</span><span class="crayon-h"> </span><span class="crayon-s">"this prog does:..."</span></div><div class="crayon-line" id="crayon-5eb04c2809f3e434070305-3"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">echo</span><span class="crayon-h"> </span><span class="crayon-s">"flags:"</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3e434070305-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">echo</span><span class="crayon-h"> </span><span class="crayon-s">"-h print help"</span></div><div class="crayon-line" id="crayon-5eb04c2809f3e434070305-5"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0001 seconds] -->
<p></p>
<p style="text-align: justify;">echo est répété à chaque ligne. A la place on a &lsquo;Here Document&rsquo; :</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f3f059925374" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
usage() {
	cat &lt;&lt;- EOF
	usage: $PROGNAME options

	Program deletes files from filesystems to release space.
	It gets config file that define fileystem paths to work on, and whitelist rules to
	keep certain files.

	OPTIONS:
		-c --config configuration file containing the rules. use --help-config to see the syntax.
		-n --pretend do not really delete, just how what you are going to do.
		-t --test run unit test to check the program
		-v --verbose Verbose. You can specify more then one -v to have more verbose
		-x --debug debug
		-h --help show this help
		   --help-config configuration help

	Examples:
		Run all tests:
		$PROGNAME --test all

		Run specific test:
		$PROGNAME --test test_string.sh

		Run:
		$PROGNAME --config /path/to/config/$PROGNAME.conf

		Just show what you are going to do:
		$PROGNAME -vn -c /path/to/config/$PROGNAME.conf
	EOF
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-8">8</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-10">10</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-12">12</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-13">13</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-14">14</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-15">15</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-16">16</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-17">17</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-18">18</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-19">19</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-20">20</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-21">21</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-22">22</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-23">23</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-24">24</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-25">25</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-26">26</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-27">27</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-28">28</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-29">29</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f3f059925374-30">30</div><div class="crayon-num" data-line="crayon-5eb04c2809f3f059925374-31">31</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-1"><span class="crayon-e">usage</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-2"><span class="crayon-h">	</span><span class="crayon-r">cat</span><span class="crayon-h"> </span><span class="crayon-o">&lt;&lt;</span><span class="crayon-o">-</span><span class="crayon-h"> </span><span class="crayon-e">EOF</span></div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-3"><span class="crayon-e">	</span><span class="crayon-v">usage</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">$PROGNAME</span><span class="crayon-h"> </span><span class="crayon-e">options</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-4">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-5"><span class="crayon-e">	</span><span class="crayon-e">Program </span><span class="crayon-e">deletes </span><span class="crayon-e">files </span><span class="crayon-e">from </span><span class="crayon-e">filesystems </span><span class="crayon-st">to</span><span class="crayon-h"> </span><span class="crayon-e">release </span><span class="crayon-v">space</span><span class="crayon-sy">.</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-6"><span class="crayon-h">	</span><span class="crayon-e">It </span><span class="crayon-e">gets </span><span class="crayon-e">config </span><span class="crayon-r">file</span><span class="crayon-h"> </span><span class="crayon-e">that </span><span class="crayon-e">define </span><span class="crayon-e">fileystem </span><span class="crayon-e">paths </span><span class="crayon-st">to</span><span class="crayon-h"> </span><span class="crayon-e">work </span><span class="crayon-v">on</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-st">and</span><span class="crayon-h"> </span><span class="crayon-e">whitelist </span><span class="crayon-e">rules </span><span class="crayon-st">to</span></div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-7"><span class="crayon-h">	</span><span class="crayon-e">keep </span><span class="crayon-e">certain </span><span class="crayon-v">files</span><span class="crayon-sy">.</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-8">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-9"><span class="crayon-h">	</span><span class="crayon-v">OPTIONS</span><span class="crayon-o">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-10"><span class="crayon-h">		</span><span class="crayon-o">-</span><span class="crayon-v">c</span><span class="crayon-h"> </span><span class="crayon-o">--</span><span class="crayon-e">config </span><span class="crayon-e">configuration </span><span class="crayon-r">file</span><span class="crayon-h"> </span><span class="crayon-e">containing </span><span class="crayon-e">the </span><span class="crayon-v">rules</span><span class="crayon-sy">.</span><span class="crayon-h"> </span><span class="crayon-st">use</span><span class="crayon-h"> </span><span class="crayon-o">--</span><span class="crayon-v">help</span><span class="crayon-o">-</span><span class="crayon-e">config </span><span class="crayon-st">to</span><span class="crayon-h"> </span><span class="crayon-e">see </span><span class="crayon-e">the </span><span class="crayon-v">syntax</span><span class="crayon-sy">.</span></div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-11"><span class="crayon-h">		</span><span class="crayon-o">-</span><span class="crayon-v">n</span><span class="crayon-h"> </span><span class="crayon-o">--</span><span class="crayon-e">pretend </span><span class="crayon-st">do</span><span class="crayon-h"> </span><span class="crayon-st">not</span><span class="crayon-h"> </span><span class="crayon-e">really </span><span class="crayon-v">delete</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-e">just </span><span class="crayon-e">how </span><span class="crayon-r">what</span><span class="crayon-h"> </span><span class="crayon-e">you </span><span class="crayon-e">are </span><span class="crayon-e">going </span><span class="crayon-st">to</span><span class="crayon-h"> </span><span class="crayon-st">do</span><span class="crayon-sy">.</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-12"><span class="crayon-h">		</span><span class="crayon-o">-</span><span class="crayon-v">t</span><span class="crayon-h"> </span><span class="crayon-o">--</span><span class="crayon-r">test</span><span class="crayon-h"> </span><span class="crayon-e">run </span><span class="crayon-e">unit </span><span class="crayon-r">test</span><span class="crayon-h"> </span><span class="crayon-st">to</span><span class="crayon-h"> </span><span class="crayon-e">check </span><span class="crayon-e">the </span><span class="crayon-v">program</span></div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-13"><span class="crayon-h">		</span><span class="crayon-o">-</span><span class="crayon-v">v</span><span class="crayon-h"> </span><span class="crayon-o">--</span><span class="crayon-e">verbose </span><span class="crayon-v">Verbose</span><span class="crayon-sy">.</span><span class="crayon-h"> </span><span class="crayon-e">You </span><span class="crayon-e">can </span><span class="crayon-e">specify </span><span class="crayon-r">more</span><span class="crayon-h"> </span><span class="crayon-st">then</span><span class="crayon-h"> </span><span class="crayon-v">one</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">v</span><span class="crayon-h"> </span><span class="crayon-st">to</span><span class="crayon-h"> </span><span class="crayon-e">have </span><span class="crayon-r">more</span><span class="crayon-h"> </span><span class="crayon-v">verbose</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-14"><span class="crayon-h">		</span><span class="crayon-o">-</span><span class="crayon-v">x</span><span class="crayon-h"> </span><span class="crayon-o">--</span><span class="crayon-e">debug </span><span class="crayon-v">debug</span></div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-15"><span class="crayon-h">		</span><span class="crayon-o">-</span><span class="crayon-v">h</span><span class="crayon-h"> </span><span class="crayon-o">--</span><span class="crayon-e">help </span><span class="crayon-e">show </span><span class="crayon-r">this</span><span class="crayon-h"> </span><span class="crayon-v">help</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-16"><span class="crayon-h">		&nbsp;&nbsp; </span><span class="crayon-o">--</span><span class="crayon-v">help</span><span class="crayon-o">-</span><span class="crayon-e">config </span><span class="crayon-e">configuration </span><span class="crayon-e">help</span></div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-17">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-18"><span class="crayon-e">	</span><span class="crayon-v">Examples</span><span class="crayon-o">:</span></div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-19"><span class="crayon-h">		</span><span class="crayon-e">Run </span><span class="crayon-e">all </span><span class="crayon-v">tests</span><span class="crayon-o">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-20"><span class="crayon-h">		</span><span class="crayon-v">$PROGNAME</span><span class="crayon-h"> </span><span class="crayon-o">--</span><span class="crayon-r">test</span><span class="crayon-h"> </span><span class="crayon-e">all</span></div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-21">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-22"><span class="crayon-e">		</span><span class="crayon-e">Run </span><span class="crayon-e">specific </span><span class="crayon-r">test</span><span class="crayon-o">:</span></div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-23"><span class="crayon-h">		</span><span class="crayon-v">$PROGNAME</span><span class="crayon-h"> </span><span class="crayon-o">--</span><span class="crayon-r">test</span><span class="crayon-h"> </span><span class="crayon-v">test_string</span><span class="crayon-e">.sh</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-24">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-25"><span class="crayon-h">		</span><span class="crayon-v">Run</span><span class="crayon-o">:</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-26"><span class="crayon-h">		</span><span class="crayon-v">$PROGNAME</span><span class="crayon-h"> </span><span class="crayon-o">--</span><span class="crayon-v">config</span><span class="crayon-h"> </span><span class="crayon-o">/</span><span class="crayon-v">path</span><span class="crayon-o">/</span><span class="crayon-st">to</span><span class="crayon-o">/</span><span class="crayon-v">config</span><span class="crayon-o">/</span><span class="crayon-v">$PROGNAME</span><span class="crayon-e">.conf</span></div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-27">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-28"><span class="crayon-h">		</span><span class="crayon-e">Just </span><span class="crayon-e">show </span><span class="crayon-r">what</span><span class="crayon-h"> </span><span class="crayon-e">you </span><span class="crayon-e">are </span><span class="crayon-e">going </span><span class="crayon-st">to</span><span class="crayon-h"> </span><span class="crayon-st">do</span><span class="crayon-o">:</span></div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-29"><span class="crayon-h">		</span><span class="crayon-v">$PROGNAME</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-v">vn</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-v">c</span><span class="crayon-h"> </span><span class="crayon-o">/</span><span class="crayon-v">path</span><span class="crayon-o">/</span><span class="crayon-st">to</span><span class="crayon-o">/</span><span class="crayon-v">config</span><span class="crayon-o">/</span><span class="crayon-v">$PROGNAME</span><span class="crayon-e">.conf</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f3f059925374-30"><span class="crayon-h">	</span><span class="crayon-i">EOF</span></div><div class="crayon-line" id="crayon-5eb04c2809f3f059925374-31"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0013 seconds] -->
<p></p>
<p style="text-align: justify;">Attention à bien utiliser des tabulations &lsquo;\t&rsquo; pour le début de chaque ligne. Dans vim vous pouvez utiliser cette astuce si votre tabulation consiste en 4 espaces :</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f41909361214" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
:s/^    /\t/</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f41909361214-1">1</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f41909361214-1"><span class="crayon-o">:</span><span class="crayon-v">s</span><span class="crayon-o">/</span><span class="crayon-o">^</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">/</span><span class="crayon-sy">\</span><span class="crayon-v">t</span><span class="crayon-o">/</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0001 seconds] -->
<p></p>
<h3 style="text-align: justify;">Arguments de ligne de commande</h3>
<p style="text-align: justify;">Voici un exemple de complément à la fonction usage d&rsquo;au-dessus. Ce code est tiré de l&rsquo;article <a href="http://kirk.webfinish.com/2009/10/bash-shell-script-to-use-getopts-with-gnu-style-long-positional-parameters/" target="_blank" rel="noopener">bash shell script to use getopts with gnu style long positional parameters</a> sur le blog de Kirk :</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f44049381452" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
cmdline() {
  # got this idea from here:
  # http://kirk.webfinish.com/2009/10/bash-shell-script-to-use-getopts-with-gnu-style-long-positional-parameters/
  local arg=
  for arg
  do
    local delim=""
    case "$arg" in
      #translate --gnu-long-options to -g (short options)
      --config) args="${args}-c ";;
      --pretend) args="${args}-n ";;
      --test) args="${args}-t ";;
      --help-config) usage_config &amp;&amp; exit 0;;
      --help) args="${args}-h ";;
      --verbose) args="${args}-v ";;
      --debug) args="${args}-x ";;
      #pass through anything else
      *) [[ "${arg:0:1}" == "-" ]] || delim="\""
         args="${args}${delim}${arg}${delim} ";;
    esac
  done

  #Reset the positional parameters to the short options
  eval set -- $args

  while getopts "nvhxt:c:" OPTION
  do
    case $OPTION in
      v)
          readonly VERBOSE=1
          ;;
      h)
          usage
          exit 0
          ;;
      x)
          readonly DEBUG='-x'
          set -x
          ;;
      t)
          RUN_TESTS=$OPTARG
          verbose VINFO "Running tests"
          ;;
      c)
          readonly CONFIG_FILE=$OPTARG
          ;;
      n)
          readonly PRETEND=1
          ;;
    esac
  done

  if [[ $recursive_testing || -z $RUN_TESTS ]]; then
    [[ ! -f $CONFIG_FILE ]] \
      &amp;&amp; eexit "You must provide --config file"
  fi
  return 0
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-8">8</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-10">10</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-12">12</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-13">13</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-14">14</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-15">15</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-16">16</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-17">17</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-18">18</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-19">19</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-20">20</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-21">21</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-22">22</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-23">23</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-24">24</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-25">25</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-26">26</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-27">27</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-28">28</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-29">29</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-30">30</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-31">31</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-32">32</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-33">33</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-34">34</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-35">35</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-36">36</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-37">37</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-38">38</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-39">39</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-40">40</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-41">41</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-42">42</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-43">43</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-44">44</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-45">45</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-46">46</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-47">47</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-48">48</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-49">49</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-50">50</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-51">51</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-52">52</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-53">53</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-54">54</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-55">55</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-56">56</div><div class="crayon-num" data-line="crayon-5eb04c2809f44049381452-57">57</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f44049381452-58">58</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f44049381452-1"><span class="crayon-e">cmdline</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-c"># got this idea from here:</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-3"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-c"># http://kirk.webfinish.com/2009/10/bash-shell-script-to-use-getopts-with-gnu-style-long-positional-parameters/</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">arg</span><span class="crayon-o">=</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-5"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-st">for</span><span class="crayon-h"> </span><span class="crayon-e">arg</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-6"><span class="crayon-e">&nbsp;&nbsp;</span><span class="crayon-st">do</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-7"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">delim</span><span class="crayon-o">=</span><span class="crayon-s">""</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-8"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-st">case</span><span class="crayon-h"> </span><span class="crayon-s">"$arg"</span><span class="crayon-h"> </span><span class="crayon-st">in</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-9"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-c">#translate --gnu-long-options to -g (short options)</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-10"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">--</span><span class="crayon-v">config</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">args</span><span class="crayon-o">=</span><span class="crayon-s">"${args}-c "</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-11"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">--</span><span class="crayon-v">pretend</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">args</span><span class="crayon-o">=</span><span class="crayon-s">"${args}-n "</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-12"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">--</span><span class="crayon-r">test</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">args</span><span class="crayon-o">=</span><span class="crayon-s">"${args}-t "</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-13"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">--</span><span class="crayon-v">help</span><span class="crayon-o">-</span><span class="crayon-v">config</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">usage_config</span><span class="crayon-h"> </span><span class="crayon-o">&amp;&amp;</span><span class="crayon-h"> </span><span class="crayon-r">exit</span><span class="crayon-h"> </span><span class="crayon-cn">0</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-14"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">--</span><span class="crayon-v">help</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">args</span><span class="crayon-o">=</span><span class="crayon-s">"${args}-h "</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-15"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">--</span><span class="crayon-v">verbose</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">args</span><span class="crayon-o">=</span><span class="crayon-s">"${args}-v "</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-16"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">--</span><span class="crayon-v">debug</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">args</span><span class="crayon-o">=</span><span class="crayon-s">"${args}-x "</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-17"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-c">#pass through anything else</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-18"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">*</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-sy">[</span><span class="crayon-h"> </span><span class="crayon-s">"${arg:0:1}"</span><span class="crayon-h"> </span><span class="crayon-o">==</span><span class="crayon-h"> </span><span class="crayon-s">"-"</span><span class="crayon-h"> </span><span class="crayon-sy">]</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-o">||</span><span class="crayon-h"> </span><span class="crayon-v">delim</span><span class="crayon-o">=</span><span class="crayon-s">"\""</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-19"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-v">args</span><span class="crayon-o">=</span><span class="crayon-s">"${args}${delim}${arg}${delim} "</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-20"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-st">esac</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-21"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-st">done</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-22">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-23"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-c">#Reset the positional parameters to the short options</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-24"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">eval </span><span class="crayon-v">set</span><span class="crayon-h"> </span><span class="crayon-o">--</span><span class="crayon-h"> </span><span class="crayon-v">$args</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-25">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-26"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-st">while</span><span class="crayon-h"> </span><span class="crayon-r">getopts</span><span class="crayon-h"> </span><span class="crayon-s">"nvhxt:c:"</span><span class="crayon-h"> </span><span class="crayon-e">OPTION</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-27"><span class="crayon-e">&nbsp;&nbsp;</span><span class="crayon-st">do</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-28"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-st">case</span><span class="crayon-h"> </span><span class="crayon-v">$OPTION</span><span class="crayon-h"> </span><span class="crayon-st">in</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-29"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">v</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-30"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-e">readonly </span><span class="crayon-v">VERBOSE</span><span class="crayon-o">=</span><span class="crayon-cn">1</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-31"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-32"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">h</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-33"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-e">usage</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-34"><span class="crayon-e">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-r">exit</span><span class="crayon-h"> </span><span class="crayon-cn">0</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-35"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-36"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">x</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-37"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-e">readonly </span><span class="crayon-v">DEBUG</span><span class="crayon-o">=</span><span class="crayon-s">'-x'</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-38"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">set</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">x</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-39"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-40"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">t</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-41"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">RUN_TESTS</span><span class="crayon-o">=</span><span class="crayon-v">$OPTARG</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-42"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-e">verbose </span><span class="crayon-i">VINFO</span><span class="crayon-h"> </span><span class="crayon-s">"Running tests"</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-43"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-44"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">c</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-45"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-e">readonly </span><span class="crayon-v">CONFIG_FILE</span><span class="crayon-o">=</span><span class="crayon-v">$OPTARG</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-46"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-47"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-v">n</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-48"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-e">readonly </span><span class="crayon-v">PRETEND</span><span class="crayon-o">=</span><span class="crayon-cn">1</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-49"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-sy">;</span><span class="crayon-sy">;</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-50"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-st">esac</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-51"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-st">done</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-52">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-53"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-st">if</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-sy">[</span><span class="crayon-h"> </span><span class="crayon-v">$recursive_testing</span><span class="crayon-h"> </span><span class="crayon-o">||</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">z</span><span class="crayon-h"> </span><span class="crayon-v">$RUN_TESTS</span><span class="crayon-h"> </span><span class="crayon-sy">]</span><span class="crayon-sy">]</span><span class="crayon-sy">;</span><span class="crayon-h"> </span><span class="crayon-st">then</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-54"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-sy">[</span><span class="crayon-sy">[</span><span class="crayon-h"> </span><span class="crayon-o">!</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">f</span><span class="crayon-h"> </span><span class="crayon-v">$CONFIG_FILE</span><span class="crayon-h"> </span><span class="crayon-sy">]</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-55"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">&amp;&amp;</span><span class="crayon-h"> </span><span class="crayon-i">eexit</span><span class="crayon-h"> </span><span class="crayon-s">"You must provide --config file"</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-56"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-st">fi</span></div><div class="crayon-line" id="crayon-5eb04c2809f44049381452-57"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-st">return</span><span class="crayon-h"> </span><span class="crayon-cn">0</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f44049381452-58"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0015 seconds] -->
<p></p>
<p style="text-align: justify;">On l&rsquo;utilise ensuite de cette façon en utilisant la variable immutable ARGS qu&rsquo;on a défini au début du script :</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f46338433966" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
main() {
cmdline $ARGS
}
main</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f46338433966-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f46338433966-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f46338433966-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f46338433966-4">4</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f46338433966-1"><span class="crayon-e">main</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f46338433966-2"><span class="crayon-i">cmdline</span><span class="crayon-h"> </span><span class="crayon-v">$ARGS</span></div><div class="crayon-line" id="crayon-5eb04c2809f46338433966-3"><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f46338433966-4"><span class="crayon-v">main</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0001 seconds] -->
<p></p>
<h3 style="text-align: justify;">Tests unitaires</h3>
<ul style="text-align: justify;">
<li>Très important dans les langages de haut niveau</li>
<li>Utilisez shunit2 pour vos tests unitaires</li>
</ul>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f47958554306" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
test_config_line_paths() {
  local s='partition cpm-all, 80-90,'

  returns "/a" "config_line_paths '$s /a, '"
  returns "/a /b/c" "config_line_paths '$s /a:/b/c, '"
  returns "/a /b /c" "config_line_paths '$s /a : /b : /c, '"
}

config_line_paths() {
  local partition_line="$@"

  echo $partition_line \
    | csv_column 3 \
    | delete_spaces \
    | column 1 \
    | colons_to_spaces
}

source /usr/bin/shunit2</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f47958554306-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f47958554306-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f47958554306-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f47958554306-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f47958554306-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f47958554306-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f47958554306-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f47958554306-8">8</div><div class="crayon-num" data-line="crayon-5eb04c2809f47958554306-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f47958554306-10">10</div><div class="crayon-num" data-line="crayon-5eb04c2809f47958554306-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f47958554306-12">12</div><div class="crayon-num" data-line="crayon-5eb04c2809f47958554306-13">13</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f47958554306-14">14</div><div class="crayon-num" data-line="crayon-5eb04c2809f47958554306-15">15</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f47958554306-16">16</div><div class="crayon-num" data-line="crayon-5eb04c2809f47958554306-17">17</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f47958554306-18">18</div><div class="crayon-num" data-line="crayon-5eb04c2809f47958554306-19">19</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f47958554306-1"><span class="crayon-e">test_config_line_paths</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f47958554306-2"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">local</span><span class="crayon-h"> </span><span class="crayon-v">s</span><span class="crayon-o">=</span><span class="crayon-s">'partition cpm-all, 80-90,'</span></div><div class="crayon-line" id="crayon-5eb04c2809f47958554306-3">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f47958554306-4"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">returns</span><span class="crayon-h"> </span><span class="crayon-s">"/a"</span><span class="crayon-h"> </span><span class="crayon-s">"config_line_paths '$s /a, '"</span></div><div class="crayon-line" id="crayon-5eb04c2809f47958554306-5"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">returns</span><span class="crayon-h"> </span><span class="crayon-s">"/a /b/c"</span><span class="crayon-h"> </span><span class="crayon-s">"config_line_paths '$s /a:/b/c, '"</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f47958554306-6"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">returns</span><span class="crayon-h"> </span><span class="crayon-s">"/a /b /c"</span><span class="crayon-h"> </span><span class="crayon-s">"config_line_paths '$s /a : /b : /c, '"</span></div><div class="crayon-line" id="crayon-5eb04c2809f47958554306-7"><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f47958554306-8">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f47958554306-9"><span class="crayon-e">config_line_paths</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f47958554306-10"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">partition_line</span><span class="crayon-o">=</span><span class="crayon-s">"$@"</span></div><div class="crayon-line" id="crayon-5eb04c2809f47958554306-11">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f47958554306-12"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">echo</span><span class="crayon-h"> </span><span class="crayon-v">$partition_line</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f47958554306-13"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-v">csv</span><span class="crayon-sy">_</span>column<span class="crayon-h"> </span><span class="crayon-cn">3</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f47958554306-14"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-v">delete</span><span class="crayon-sy">_</span>spaces<span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f47958554306-15"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-i">column</span><span class="crayon-h"> </span><span class="crayon-cn">1</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f47958554306-16"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-v">colons_to</span><span class="crayon-sy">_</span>spaces</div><div class="crayon-line" id="crayon-5eb04c2809f47958554306-17"><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f47958554306-18">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f47958554306-19"><span class="crayon-v">source</span><span class="crayon-h"> </span><span class="crayon-o">/</span><span class="crayon-v">usr</span><span class="crayon-o">/</span><span class="crayon-v">bin</span><span class="crayon-o">/</span><span class="crayon-v">shunit2</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0005 seconds] -->
<p></p>
<p style="text-align: justify;">Voici un autre exemple sur la commande df :</p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c2809f49204682801" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div><span class="crayon-language">Shell</span></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
DF=df

mock_df_with_eols() {
    cat &lt;&lt;- EOF
    Filesystem           1K-blocks      Used Available Use% Mounted on
    /very/long/device/path
                         124628916  23063572 100299192  19% /
    EOF
}

test_disk_size() {
  returns 1000 "disk_size /dev/sda1"

  DF=mock_df_with_eols
  returns 124628916 "disk_size /very/long/device/path"
}

df_column() {
  local disk_device=$1
  local column=$2

  $DF $disk_device \
    | grep -v 'Use%' \
    | tr '\n' ' ' \
    | awk "{print \$$column}"
}

disk_size() {
  local disk_device=$1

  df_column $disk_device 2
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-2">2</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-4">4</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-6">6</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-8">8</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-10">10</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-12">12</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-13">13</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-14">14</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-15">15</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-16">16</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-17">17</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-18">18</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-19">19</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-20">20</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-21">21</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-22">22</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-23">23</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-24">24</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-25">25</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-26">26</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-27">27</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-28">28</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-29">29</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-30">30</div><div class="crayon-num" data-line="crayon-5eb04c2809f49204682801-31">31</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c2809f49204682801-32">32</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c2809f49204682801-1"><span class="crayon-r">DF</span><span class="crayon-o">=</span><span class="crayon-r">df</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-2">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-3"><span class="crayon-e">mock_df_with_eols</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-4"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-r">cat</span><span class="crayon-h"> </span><span class="crayon-o">&lt;&lt;</span><span class="crayon-o">-</span><span class="crayon-h"> </span><span class="crayon-e">EOF</span></div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-5"><span class="crayon-e">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-i">Filesystem</span><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">1K</span><span class="crayon-o">-</span><span class="crayon-e">blocks&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-e">Used </span><span class="crayon-e">Available </span><span class="crayon-st">Use</span><span class="crayon-o">%</span><span class="crayon-h"> </span><span class="crayon-e">Mounted </span><span class="crayon-v">on</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-6"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">/</span><span class="crayon-v">very</span><span class="crayon-o">/</span><span class="crayon-t">long</span><span class="crayon-o">/</span><span class="crayon-v">device</span><span class="crayon-o">/</span><span class="crayon-i">path</span></div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-7"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-cn">124628916</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">23063572</span><span class="crayon-h"> </span><span class="crayon-cn">100299192</span><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-cn">19</span><span class="crayon-o">%</span><span class="crayon-h"> </span><span class="crayon-o">/</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-8"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-i">EOF</span></div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-9"><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-10">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-11"><span class="crayon-e">test_disk_size</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-12"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-i">returns</span><span class="crayon-h"> </span><span class="crayon-cn">1000</span><span class="crayon-h"> </span><span class="crayon-s">"disk_size /dev/sda1"</span></div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-13">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-14"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-r">DF</span><span class="crayon-o">=</span><span class="crayon-e">mock_df_with_eols</span></div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-15"><span class="crayon-e">&nbsp;&nbsp;</span><span class="crayon-i">returns</span><span class="crayon-h"> </span><span class="crayon-cn">124628916</span><span class="crayon-h"> </span><span class="crayon-s">"disk_size /very/long/device/path"</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-16"><span class="crayon-sy">}</span></div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-17">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-18"><span class="crayon-e">df_column</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-19"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">disk_device</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-20"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">column</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">2</span></div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-21">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-22"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">$DF</span><span class="crayon-h"> </span><span class="crayon-v">$disk_device</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-23"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">grep</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">v</span><span class="crayon-h"> </span><span class="crayon-s">'Use%'</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-24"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">tr</span><span class="crayon-h"> </span><span class="crayon-s">'\n'</span><span class="crayon-h"> </span><span class="crayon-s">' '</span><span class="crayon-h"> </span><span class="crayon-sy">\</span></div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-25"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-r">awk</span><span class="crayon-h"> </span><span class="crayon-s">"{print \$$column}"</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-26"><span class="crayon-sy">}</span></div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-27">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-28"><span class="crayon-e">disk_size</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-29"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-e">local </span><span class="crayon-v">disk_device</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-cn">1</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-30">&nbsp;</div><div class="crayon-line" id="crayon-5eb04c2809f49204682801-31"><span class="crayon-h">&nbsp;&nbsp;</span><span class="crayon-v">df</span><span class="crayon-sy">_</span>column<span class="crayon-h"> </span><span class="crayon-v">$disk_device</span><span class="crayon-h"> </span><span class="crayon-cn">2</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c2809f49204682801-32"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0008 seconds] -->
<p></p>
<p style="text-align: justify;">Ici il y a une exception, pour les tests je déclare DF au niveau global et pas en lecture seule. C&rsquo;est parce que shunit2 n&rsquo;autorise pas les changements de fonctions au niveau global.</p>
<hr />
<p style="text-align: justify;">Les plus aguerris au développement logiciel trouveront peut-être évidents ces constructions de scripts, pour ma part j&rsquo;avais déjà lu certains de ces conseils, notamment pour Python. C&rsquo;est sympa de voir qu&rsquo;on peut réutiliser les mêmes concepts pour Bash, par défaut c&rsquo;est un langage particulièrement permissif, à l&rsquo;image de PHP. Il n&rsquo;en faut pas plus pour que les deux se trainent une réputation désastreuse.</p>
<p style="text-align: justify;">
</div>			<!-- <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="https://blog.seboss666.info/2020/04/programmation-defensive-en-bash/"
    dc:identifier="https://blog.seboss666.info/2020/04/programmation-defensive-en-bash/"
    dc:title="Programmation défensive en bash"
    trackback:ping="https://blog.seboss666.info/2020/04/programmation-defensive-en-bash/trackback/" />
</rdf:RDF> -->
			<div class="page-links"></div>			
		</div>
			
		<div class="postinfo clearfix">
			<div class="meta-comments">
				<a href="https://blog.seboss666.info/2020/04/programmation-defensive-en-bash/#comments">4</a>			</div>

		
			<span class="meta-category">
				<a href="https://blog.seboss666.info/category/astuces/" rel="category tag">Astuces</a>			</span>

		
				<span class="meta-tags">
					<a href="https://blog.seboss666.info/tag/bash/" rel="tag">bash</a>, <a href="https://blog.seboss666.info/tag/clarte/" rel="tag">clarté</a>, <a href="https://blog.seboss666.info/tag/defensive/" rel="tag">défensive</a>, <a href="https://blog.seboss666.info/tag/pratique/" rel="tag">pratique</a>, <a href="https://blog.seboss666.info/tag/programmation/" rel="tag">programmation</a>, <a href="https://blog.seboss666.info/tag/qualite/" rel="tag">qualité</a>, <a href="https://blog.seboss666.info/tag/securite/" rel="tag">sécurité</a>				</span>

			</div>

	</article>
			
		
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Navigation de l’article</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://blog.seboss666.info/2020/04/deployer-un-service-consul-mais-surtout-le-securiser/" rel="prev">&laquo; Déployer un service Consul, mais surtout le sécuriser !</a></div></div>
	</nav>			
				
		    <div class="wpdiscuz_top_clearing"></div>
    <div id="comments" class="comments-area"><div id="respond" style="width: 0;height: 0;clear: both;margin: 0;padding: 0;"></div>            <h3 id="wc-comment-header">
                                    <div class="wpdiscuz-comment-count">
                        <div class="wpd-cc-value">4</div>
                        <div class="wpd-cc-arrow"></div>
                    </div>
                                Poster un Commentaire            </h3>
                    <div id="wpcomm" class="wpdiscuz_unauth wpd-default">
            <div class="wpdiscuz-form-top-bar">
                <div class="wpdiscuz-ftb-left">
                                                            <div id="wc_show_hide_loggedin_username">
                                            </div>
                </div>
                                <div class="wpd-clear"></div>
            </div>


                        <div class="wc_social_plugin_wrapper">
                            </div>
                    <div class="wc-form-wrapper wc-main-form-wrapper"  id='wc-main-form-wrapper-0_0' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                                        <form class="wc_comm_form wc_main_comm_form" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">

                                                                                                        <div class="wc-field-avatararea">
                                        <img alt='avatar' src='https://secure.gravatar.com/avatar/?s=40&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=80&#038;d=retro&#038;r=g 2x' class='avatar avatar-40 photo avatar-default' height='40' width='40' />                                    </div>
                                
                                <textarea id="wc-textarea-0_0"   placeholder="Rejoindre la discussion..." required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                                <input value="" required="required" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Nom*" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                                <input value="" required="required" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*">
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="URL du site Web">
                                            </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-captcha wpdiscuz-item wc_captcha-wrapper">
            <div class="wc-captcha-input">
                <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha"  class="wpd-field wc_field_captcha" placeholder="Code" title="Insérer le code CAPTCHA">
            </div>
            <div class="wc-label wc-captcha-label">
                                <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://blog.seboss666.info/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5eb04c281c3c2"  width="80" height="26"/></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img  alt="refresh" class="" src="https://blog.seboss666.info/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></a>
                <input type="hidden" id="c5eb04c281c3c2" class="wpdiscuz-cnonce" name="cnonce" value="c5eb04c281c3c2" />
            </div>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" title="Notifier des nouvelles réponses à tous mes commentaires">
                            <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" checked="checked"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Poster le Commentaire">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id">
                </form>
                    <div class="wpdiscuz-form-bottom-bar">
                    <div class="wpdiscuz-fbb-left">
                                                                        <div class="wpdiscuz-stat wpd-stat-threads wpd-tooltip-left">
                        <i class="fas fa-align-left fa-rotate-180" data-fa-transform="rotate-180"></i><span class="wpd-stat-threads-count">4</span>
                        <wpdtip>Fils de commentaires</wpdtip>
                    </div>
                                                                                        <div class="wpdiscuz-stat wpd-stat-replies wpd-tooltip-left">
                        <i class="far fa-comments"></i><span class="wpd-stat-replies-count">0</span>
                        <wpdtip>Réponses de fil</wpdtip>
                    </div>
                                                                                        <div class="wpdiscuz-stat wpd-stat-subscribers wpd-tooltip-left">
                        <i class="fas fa-rss"></i><span>1</span>
                        <wpdtip>Abonnés</wpdtip>
                    </div>&nbsp;
                                                                    
                    <div class="wpdiscuz-stat wpd-stat-reacted wpd-tooltip">
                        <i class="fas fa-bolt"></i>
                        <wpdtip>Commentaire avec le plus de réactions</wpdtip>
                    </div>
                                                                    <div class="wpdiscuz-stat wpd-stat-hot wpd-tooltip">
                        <i class="fab fa-hotjar"></i>
                        <wpdtip>Le plus populaire des commentaires</wpdtip>
                    </div>
                            </div>
                                        <div class="wpdiscuz-fbb-right">
                                                        <div class="wpdiscuz-stat wpd-stat-users wpd-tooltip">
                        <i class="fas fa-user-circle"></i> <span class="wpd-stat-authors-count">4</span>
                        <wpdtip>Auteurs du commentaire</wpdtip>
                    </div>
                                                                                                            <div class="wpdiscuz-users wpd-tooltip-right">
                        <img alt='Thibault' src='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/cd1491c074151e7ae6c919ede6a77e14.gif' srcset='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/cd1491c074151e7ae6c919ede6a77e14.gif 2x' class='avatar avatar-64 photo' height='64' width='64' title='Thibault'/><img alt='Sky' src='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/b22ce98cb8250936914f54e6bffc56a9.gif' srcset='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/b22ce98cb8250936914f54e6bffc56a9.gif 2x' class='avatar avatar-64 photo' height='64' width='64' title='Sky'/><img alt='Toto' src='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/5e97dde8285093128059298e52eeeb55.gif' srcset='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/5e97dde8285093128059298e52eeeb55.gif 2x' class='avatar avatar-64 photo' height='64' width='64' title='Toto'/><img alt='Éric' src='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/e6896c353c8420126e8a6d86293c1c8c.gif' srcset='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/e6896c353c8420126e8a6d86293c1c8c.gif 2x' class='avatar avatar-64 photo' height='64' width='64' title='Éric'/>                        <wpdtip>Auteurs de commentaires récents</wpdtip>
                    </div>
                            </div>
                <div class="wpd-clear"></div>
    </div>
            </div>
                <div id = "wpdiscuz_hidden_secondary_form" style = "display: none;">
                    <div class="wc-form-wrapper wc-secondary-form-wrapper"  id='wc-secondary-form-wrapper-wpdiscuzuniqueid'  style='display: none;' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                            <div class="wc-secondary-forms-social-content"></div><div class="clearfix"></div>
                                        <form class="wc_comm_form wc-secondary-form-wrapper" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">

                                                                                                        <div class="wc-field-avatararea">
                                        <img alt='avatar' src='https://secure.gravatar.com/avatar/?s=48&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=retro&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' />                                    </div>
                                
                                <textarea id="wc-textarea-wpdiscuzuniqueid"   placeholder="Rejoindre la discussion..." required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                                <input value="" required="required" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Nom*" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                                <input value="" required="required" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*">
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="URL du site Web">
                                            </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-captcha wpdiscuz-item wc_captcha-wrapper">
            <div class="wc-captcha-input">
                <input type="text" maxlength="5" value="" autocomplete="off" required="required" name="wc_captcha"  class="wpd-field wc_field_captcha" placeholder="Code" title="Insérer le code CAPTCHA">
            </div>
            <div class="wc-label wc-captcha-label">
                                <a class="wpdiscuz-nofollow" href="#" rel="nofollow"><img alt="wpdiscuz_captcha" class="wc_captcha_img" src="https://blog.seboss666.info/wp-content/plugins/wpdiscuz/utils/captcha/captcha.php?key=c5eb04c281ca42"  width="80" height="26"/></a><a class="wpdiscuz-nofollow wc_captcha_refresh_img" href="#" rel="nofollow"><img  alt="refresh" class="" src="https://blog.seboss666.info/wp-content/plugins/wpdiscuz/assets/img/captcha-loading.png" width="16" height="16"/></a>
                <input type="hidden" id="c5eb04c281ca42" class="wpdiscuz-cnonce" name="cnonce" value="c5eb04c281ca42" />
            </div>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" title="Notifier des nouvelles réponses à tous mes commentaires">
                            <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" checked="checked"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Poster le Commentaire">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id">
                </form>
                        </div>
                </div>
        <div id="wtr-comments-end"></div>                                   

                                    <div class="wpdiscuz-front-actions">
                                                    <div class="wpdiscuz-sbs-wrap">
                                <span><i class="far fa-envelope" aria-hidden="true"></i>&nbsp; S’abonner &nbsp;<i class="fas fa-caret-down" aria-hidden="true"></i></span>
                            </div>
                                                                        
                            <div class="wpdiscuz-sort-buttons" style="font-size:14px; color: #777;">
                                <i class="fas fa-caret-up" aria-hidden="true"></i> 
                                <span class="wpdiscuz-sort-button wpdiscuz-date-sort-desc ">le plus récent</span> <i class="fas fa-caret-up" aria-hidden="true"></i> 
                                <span class="wpdiscuz-sort-button wpdiscuz-date-sort-asc wpdiscuz-sort-button-active">le plus ancien</span>
                                                            </div>
                                                <div class="clearfix"></div>
                    </div>
                                                    <div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
                                                    <form action="https://blog.seboss666.info/wp-admin/admin-ajax.php?action=addSubscription" method="post" id="wpdiscuz-subscribe-form">
                                <div class="wpdiscuz-subscribe-form-intro">Notifier de </div>
                                <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                    <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" >
                                                                                    <option value="post">nouveaux commentaires de suivi</option>
                                                                                                                            <option value="all_comment" >nouvelles réponses à mes commentaires</option>
                                                                            </select>
                                </div>
                                                                    <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                        <input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="E-mail"/>
                                    </div>
                                                                <div class="wpdiscuz-subscribe-form-button">
                                    <input id="wpdiscuz_subscription_button" type="submit" value="&rsaquo;" name="wpdiscuz_subscription_button" />
                                </div> 
                                                                <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="36d5f0d69e" /><input type="hidden" name="_wp_http_referer" value="/2020/04/programmation-defensive-en-bash/" />                                                                <input type="hidden" value="2935" name="wpdiscuzSubscriptionPostId" />
                            </form>
                                                <div class="wpdiscuz_clear"></div>
                                            </div>
                    
                                <div id="wcThreadWrapper" class="wc-thread-wrapper">
                    <div id="wc-comm-2966_0" class="wc-comment wc-blog-guest wc_comment_level-1"><div class="wc-comment-left "><div class="wpd-xborder"></div><img alt='Éric' src='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/e6896c353c8420126e8a6d86293c1c8c.gif' srcset='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/e6896c353c8420126e8a6d86293c1c8c.gif 2x' class='avatar avatar-64 photo' height='64' width='64' /><div class="wc-blog-guest wc-comment-label"><span>Invité</span></div></div><div id="comment-2966" class="wc-comment-right"><div class="wc-comment-header"><div class="wc-comment-author ">Éric</div><div class="wc-comment-link"></div><div class="wpdiscuz_clear"></div></div><div class="wc-comment-text"><p>Merci pour ce beau recueil de bonnes pratiques !</p>
</div><div class="wc-comment-footer"><div class="wc-footer-left"><span class="wc-reply-button wc-cta-button" title="Répondre"><i class="far fa-comments" aria-hidden="true"></i> Répondre</span></div><div class="wc-footer-right"><div class="wc-comment-date"><i class="far fa-clock" aria-hidden="true"></i>27/04/2020 19:18</div><div class="wc-toggle"></div></div><div class="wpdiscuz_clear"></div></div></div><div class="wpdiscuz-comment-message"></div><div id="wpdiscuz_form_anchor-2966_0"  class="wpdiscuz_clear"></div></div><div id="wc-comm-2971_0" class="wc-comment wc-blog-guest wc_comment_level-1"><div class="wc-comment-left "><div class="wpd-xborder"></div><img alt='Toto' src='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/5e97dde8285093128059298e52eeeb55.gif' srcset='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/5e97dde8285093128059298e52eeeb55.gif 2x' class='avatar avatar-64 photo' height='64' width='64' /><div class="wc-blog-guest wc-comment-label"><span>Invité</span></div></div><div id="comment-2971" class="wc-comment-right"><div class="wc-comment-header"><div class="wc-comment-author ">Toto</div><div class="wc-comment-link"></div><div class="wpdiscuz_clear"></div></div><div class="wc-comment-text"><p>Salut,</p>
<p>Bizarre, il manque quelques règles de protection. <code>$ARGS</code> est un tableau. Il faut protéger les valeurs avec <code>${ARGS[@]}</code>, non ?</p>
<p>Un avis sur shellcheck ? À mon avis la référence dans l&rsquo;analyze statique de code shell.</p>
<p>Super article au demeurant ! Merci !!</p>
</div><div class="wc-comment-footer"><div class="wc-footer-left"><span class="wc-reply-button wc-cta-button" title="Répondre"><i class="far fa-comments" aria-hidden="true"></i> Répondre</span></div><div class="wc-footer-right"><div class="wc-comment-date"><i class="far fa-clock" aria-hidden="true"></i>28/04/2020 09:15</div><div class="wc-toggle"></div></div><div class="wpdiscuz_clear"></div></div></div><div class="wpdiscuz-comment-message"></div><div id="wpdiscuz_form_anchor-2971_0"  class="wpdiscuz_clear"></div></div><div id="wc-comm-2973_0" class="wc-comment wc-blog-guest wc_comment_level-1"><div class="wc-comment-left "><div class="wpd-xborder"></div><img alt='Sky' src='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/b22ce98cb8250936914f54e6bffc56a9.gif' srcset='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/b22ce98cb8250936914f54e6bffc56a9.gif 2x' class='avatar avatar-64 photo' height='64' width='64' /><div class="wc-blog-guest wc-comment-label"><span>Invité</span></div></div><div id="comment-2973" class="wc-comment-right"><div class="wc-comment-header"><div class="wc-comment-author ">Sky</div><div class="wc-comment-link"></div><div class="wpdiscuz_clear"></div></div><div class="wc-comment-text"><p>Merci de l&rsquo;article.<br />
En plus de la majorité de ces pratiques j&rsquo;utilise également cet entête : </p>
<p></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5eb04c280a5dd557839266" class="crayon-syntax crayon-theme-monokai crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 14px !important; line-height: 17px !important;">
		
			<div class="crayon-toolbar" data-settings=" show" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 14px !important;height: 21px !important; line-height: 21px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 19.6px !important; line-height: 19.6px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 14px !important; line-height: 17px !important;">
set -e -u -o pipefail
IFS=$'\n\t'
on_error() { echo "Error on or near line $1; exiting with status $2"; exit "$2"; }
trap 'on_error ${LINENO} $?' ERR</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 14px !important; line-height: 17px !important;"><div class="crayon-num" data-line="crayon-5eb04c280a5dd557839266-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c280a5dd557839266-2">2</div><div class="crayon-num" data-line="crayon-5eb04c280a5dd557839266-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5eb04c280a5dd557839266-4">4</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 14px !important; line-height: 17px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5eb04c280a5dd557839266-1"><span class="crayon-v">set</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-v">e</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-v">u</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">o</span><span class="crayon-h"> </span><span class="crayon-e">pipefail</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c280a5dd557839266-2"><span class="crayon-v">IFS</span><span class="crayon-o">=</span><span class="crayon-sy">$</span><span class="crayon-s">'\n\t'</span></div><div class="crayon-line" id="crayon-5eb04c280a5dd557839266-3"><span class="crayon-e">on_error</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span><span class="crayon-h"> </span><span class="crayon-i">echo</span><span class="crayon-h"> </span><span class="crayon-s">"Error on or near line $1; exiting with status $2"</span><span class="crayon-sy">;</span><span class="crayon-h"> </span><span class="crayon-i">exit</span><span class="crayon-h"> </span><span class="crayon-s">"$2"</span><span class="crayon-sy">;</span><span class="crayon-h"> </span><span class="crayon-sy">}</span></div><div class="crayon-line crayon-striped-line" id="crayon-5eb04c280a5dd557839266-4"><span class="crayon-i">trap</span><span class="crayon-h"> </span><span class="crayon-s">'on_error ${LINENO} $?'</span><span class="crayon-h"> </span><span class="crayon-v">ERR</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0002 seconds] -->
<p></p>
<p>Issu de cet excellent article : <a href="http://redsymbol.net/articles/unofficial-bash-strict-mode/" rel="nofollow">http://redsymbol.net/articles/unofficial-bash-strict-mode/</a></p>
</div><div class="wc-comment-footer"><div class="wc-footer-left"><span class="wc-reply-button wc-cta-button" title="Répondre"><i class="far fa-comments" aria-hidden="true"></i> Répondre</span></div><div class="wc-footer-right"><div class="wc-comment-date"><i class="far fa-clock" aria-hidden="true"></i>28/04/2020 16:16</div><div class="wc-toggle"></div></div><div class="wpdiscuz_clear"></div></div></div><div class="wpdiscuz-comment-message"></div><div id="wpdiscuz_form_anchor-2973_0"  class="wpdiscuz_clear"></div></div><div id="wc-comm-2974_0" class="wc-comment wc-blog-guest wc_comment_level-1"><div class="wc-comment-left "><div class="wpd-xborder"></div><img alt='Thibault' src='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/cd1491c074151e7ae6c919ede6a77e14.gif' srcset='https://blog.seboss666.info/wp-content/uploads/wpdiscuz/cache/gravatars/cd1491c074151e7ae6c919ede6a77e14.gif 2x' class='avatar avatar-64 photo' height='64' width='64' /><div class="wc-blog-guest wc-comment-label"><span>Invité</span></div></div><div id="comment-2974" class="wc-comment-right"><div class="wc-comment-header"><div class="wc-comment-author ">Thibault</div><div class="wc-comment-link"></div><div class="wpdiscuz_clear"></div></div><div class="wc-comment-text"><p>Super intéressant cet article, dans mes favoris sur Bash. La partie sur l&rsquo;usage est maintenant une évidence, alors que je tourne sur du echo dans tous mes scripts :facepalm</p>
</div><div class="wc-comment-footer"><div class="wc-footer-left"><span class="wc-reply-button wc-cta-button" title="Répondre"><i class="far fa-comments" aria-hidden="true"></i> Répondre</span></div><div class="wc-footer-right"><div class="wc-comment-date"><i class="far fa-clock" aria-hidden="true"></i>29/04/2020 11:22</div><div class="wc-toggle"></div></div><div class="wpdiscuz_clear"></div></div></div><div class="wpdiscuz-comment-message"></div><div id="wpdiscuz_form_anchor-2974_0"  class="wpdiscuz_clear"></div></div>                
                    <div class="wpdiscuz-comment-pagination">
                                            </div>
                </div>
                <div class="wpdiscuz_clear"></div>
                                                                                </div>
        </div>
        <div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar wpdiscuz-loading-bar-unauth"></div>
        		
		</section>
		
		
	<section id="sidebar" class="secondary clearfix" role="complementary">

		<aside id="archives-2" class="widget widget_archive"><h3 class="widgettitle"><span>Archives</span></h3>		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Sélectionner un mois</option>
				<option value='https://blog.seboss666.info/2020/04/'> avril 2020 </option>
	<option value='https://blog.seboss666.info/2020/03/'> mars 2020 </option>
	<option value='https://blog.seboss666.info/2020/01/'> janvier 2020 </option>
	<option value='https://blog.seboss666.info/2019/12/'> décembre 2019 </option>
	<option value='https://blog.seboss666.info/2019/11/'> novembre 2019 </option>
	<option value='https://blog.seboss666.info/2019/09/'> septembre 2019 </option>
	<option value='https://blog.seboss666.info/2019/08/'> août 2019 </option>
	<option value='https://blog.seboss666.info/2019/07/'> juillet 2019 </option>
	<option value='https://blog.seboss666.info/2019/06/'> juin 2019 </option>
	<option value='https://blog.seboss666.info/2019/05/'> mai 2019 </option>
	<option value='https://blog.seboss666.info/2019/04/'> avril 2019 </option>
	<option value='https://blog.seboss666.info/2019/03/'> mars 2019 </option>
	<option value='https://blog.seboss666.info/2019/02/'> février 2019 </option>
	<option value='https://blog.seboss666.info/2019/01/'> janvier 2019 </option>
	<option value='https://blog.seboss666.info/2018/12/'> décembre 2018 </option>
	<option value='https://blog.seboss666.info/2018/11/'> novembre 2018 </option>
	<option value='https://blog.seboss666.info/2018/10/'> octobre 2018 </option>
	<option value='https://blog.seboss666.info/2018/09/'> septembre 2018 </option>
	<option value='https://blog.seboss666.info/2018/08/'> août 2018 </option>
	<option value='https://blog.seboss666.info/2018/07/'> juillet 2018 </option>
	<option value='https://blog.seboss666.info/2018/06/'> juin 2018 </option>
	<option value='https://blog.seboss666.info/2018/05/'> mai 2018 </option>
	<option value='https://blog.seboss666.info/2018/04/'> avril 2018 </option>
	<option value='https://blog.seboss666.info/2018/03/'> mars 2018 </option>
	<option value='https://blog.seboss666.info/2018/02/'> février 2018 </option>
	<option value='https://blog.seboss666.info/2018/01/'> janvier 2018 </option>
	<option value='https://blog.seboss666.info/2017/12/'> décembre 2017 </option>
	<option value='https://blog.seboss666.info/2017/11/'> novembre 2017 </option>
	<option value='https://blog.seboss666.info/2017/10/'> octobre 2017 </option>
	<option value='https://blog.seboss666.info/2017/09/'> septembre 2017 </option>
	<option value='https://blog.seboss666.info/2017/08/'> août 2017 </option>
	<option value='https://blog.seboss666.info/2017/07/'> juillet 2017 </option>
	<option value='https://blog.seboss666.info/2017/06/'> juin 2017 </option>
	<option value='https://blog.seboss666.info/2017/05/'> mai 2017 </option>
	<option value='https://blog.seboss666.info/2017/04/'> avril 2017 </option>
	<option value='https://blog.seboss666.info/2017/03/'> mars 2017 </option>
	<option value='https://blog.seboss666.info/2017/02/'> février 2017 </option>
	<option value='https://blog.seboss666.info/2017/01/'> janvier 2017 </option>
	<option value='https://blog.seboss666.info/2016/12/'> décembre 2016 </option>
	<option value='https://blog.seboss666.info/2016/11/'> novembre 2016 </option>
	<option value='https://blog.seboss666.info/2016/10/'> octobre 2016 </option>
	<option value='https://blog.seboss666.info/2016/09/'> septembre 2016 </option>
	<option value='https://blog.seboss666.info/2016/08/'> août 2016 </option>
	<option value='https://blog.seboss666.info/2016/07/'> juillet 2016 </option>
	<option value='https://blog.seboss666.info/2016/06/'> juin 2016 </option>
	<option value='https://blog.seboss666.info/2016/05/'> mai 2016 </option>
	<option value='https://blog.seboss666.info/2016/04/'> avril 2016 </option>
	<option value='https://blog.seboss666.info/2016/03/'> mars 2016 </option>
	<option value='https://blog.seboss666.info/2016/02/'> février 2016 </option>
	<option value='https://blog.seboss666.info/2016/01/'> janvier 2016 </option>
	<option value='https://blog.seboss666.info/2015/12/'> décembre 2015 </option>
	<option value='https://blog.seboss666.info/2015/11/'> novembre 2015 </option>
	<option value='https://blog.seboss666.info/2015/10/'> octobre 2015 </option>
	<option value='https://blog.seboss666.info/2015/09/'> septembre 2015 </option>
	<option value='https://blog.seboss666.info/2015/08/'> août 2015 </option>
	<option value='https://blog.seboss666.info/2015/07/'> juillet 2015 </option>
	<option value='https://blog.seboss666.info/2015/06/'> juin 2015 </option>
	<option value='https://blog.seboss666.info/2015/05/'> mai 2015 </option>
	<option value='https://blog.seboss666.info/2015/04/'> avril 2015 </option>
	<option value='https://blog.seboss666.info/2015/03/'> mars 2015 </option>
	<option value='https://blog.seboss666.info/2015/02/'> février 2015 </option>
	<option value='https://blog.seboss666.info/2015/01/'> janvier 2015 </option>
	<option value='https://blog.seboss666.info/2014/12/'> décembre 2014 </option>
	<option value='https://blog.seboss666.info/2014/11/'> novembre 2014 </option>
	<option value='https://blog.seboss666.info/2014/10/'> octobre 2014 </option>
	<option value='https://blog.seboss666.info/2014/09/'> septembre 2014 </option>
	<option value='https://blog.seboss666.info/2014/08/'> août 2014 </option>
	<option value='https://blog.seboss666.info/2014/07/'> juillet 2014 </option>
	<option value='https://blog.seboss666.info/2014/06/'> juin 2014 </option>
	<option value='https://blog.seboss666.info/2014/05/'> mai 2014 </option>
	<option value='https://blog.seboss666.info/2014/04/'> avril 2014 </option>
	<option value='https://blog.seboss666.info/2014/03/'> mars 2014 </option>
	<option value='https://blog.seboss666.info/2014/02/'> février 2014 </option>
	<option value='https://blog.seboss666.info/2014/01/'> janvier 2014 </option>
	<option value='https://blog.seboss666.info/2013/12/'> décembre 2013 </option>
	<option value='https://blog.seboss666.info/2013/11/'> novembre 2013 </option>
	<option value='https://blog.seboss666.info/2013/10/'> octobre 2013 </option>
	<option value='https://blog.seboss666.info/2013/09/'> septembre 2013 </option>

		</select>
		</aside><aside id="text-11" class="widget widget_text"><h3 class="widgettitle"><span>La Quadrature a besoin de vous</span></h3>			<div class="textwidget"><p style="text-align:center;"><a href="https://soutien.laquadrature.net/" title="Soutenons La Quadrature du Net !"><img src="/support_lqdn_250_fr.gif" alt="Soutenons La Quadrature du Net !" /></a></p></div>
		</aside><aside id="text-4" class="widget widget_text"><h3 class="widgettitle"><span>Favoris</span></h3>			<div class="textwidget"><p><a href="http://www.manjaro.org/" target="_blank">Manjaro.org</a><br />
 <a href="http://www.nextinpact.com" target="_blank">Next INpact</a><br />
<a href="http://www.gamalive.com" target="_blank">GamAlive</a><br />
<a href="http://linuxfr.org" target="_blank">LinuxFr.org</a><br />
<a href="http://homeserver-diy.net" target="_blank">HomeServer.DIY</a><br />
<a href="http://blog-libre.org" target="_blank">Blog Libre</a><br />
<a href="http://la-vache-libre.org" target="_blank">La Vache Libre</a><br />
<a href="http://www.it-connect.fr" target="_blank">IT-Connect</a><br />
<a href="http://computerz.solutions/" target="_blank">Computerz Solutions</a><br />
<a href="http://maviesansgluten.over-blog.com/" target="_blank">Ma vie sans gluten</a><br />
<a href="http://genma.free.fr" target="_blank">Le blog de Genma</a></p>
</div>
		</aside><aside id="text-6" class="widget widget_text"><h3 class="widgettitle"><span>Licence</span></h3>			<div class="textwidget"><p style="text-align: center;font-weight:bold;"><a rel="license" href="http://creativecommons.org/licenses/by-nc/3.0/fr/"><img alt="Licence Creative Commons" style="border-width:0" src="/wp-content/uploads/2016/01/88x31.png" /></a><br />Sauf mention contraire, le contenu de ce site est mis à disposition sous licence <a href="http://creativecommons.org/licenses/by-nc/3.0/fr/" target="_blank">Creative Commons BY-NC v3.0</a></p></div>
		</aside><aside id="text-10" class="widget widget_text"><h3 class="widgettitle"><span>Cookies</span></h3>			<div class="textwidget">Bien évidemment ce site utilise des cookies. J'ai détaillé leur utilisation et la façon de s'en passer dans <a href="/2015/01/a-propos-des-cookies-sur-ce-blog-et-comment-les-interdire-si-besoin/">cet article</a>.</div>
		</aside><aside id="tag_cloud-3" class="widget widget_tag_cloud"><h3 class="widgettitle"><span>Étiquettes</span></h3><div class="tagcloud"><a href="https://blog.seboss666.info/tag/android/" class="tag-cloud-link tag-link-52 tag-link-position-1" style="font-size: 11.243902439024pt;" aria-label="android (16 éléments)">android</a>
<a href="https://blog.seboss666.info/tag/apache/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 9.8780487804878pt;" aria-label="apache (13 éléments)">apache</a>
<a href="https://blog.seboss666.info/tag/bash/" class="tag-cloud-link tag-link-198 tag-link-position-3" style="font-size: 9.8780487804878pt;" aria-label="bash (13 éléments)">bash</a>
<a href="https://blog.seboss666.info/tag/blog/" class="tag-cloud-link tag-link-169 tag-link-position-4" style="font-size: 8.6829268292683pt;" aria-label="blog (11 éléments)">blog</a>
<a href="https://blog.seboss666.info/tag/budget/" class="tag-cloud-link tag-link-1321 tag-link-position-5" style="font-size: 8pt;" aria-label="budget (10 éléments)">budget</a>
<a href="https://blog.seboss666.info/tag/configuration/" class="tag-cloud-link tag-link-336 tag-link-position-6" style="font-size: 9.1951219512195pt;" aria-label="configuration (12 éléments)">configuration</a>
<a href="https://blog.seboss666.info/tag/controle/" class="tag-cloud-link tag-link-148 tag-link-position-7" style="font-size: 9.8780487804878pt;" aria-label="contrôle (13 éléments)">contrôle</a>
<a href="https://blog.seboss666.info/tag/conversion/" class="tag-cloud-link tag-link-86 tag-link-position-8" style="font-size: 9.8780487804878pt;" aria-label="conversion (13 éléments)">conversion</a>
<a href="https://blog.seboss666.info/tag/debian/" class="tag-cloud-link tag-link-9 tag-link-position-9" style="font-size: 13.121951219512pt;" aria-label="debian (21 éléments)">debian</a>
<a href="https://blog.seboss666.info/tag/depannage-2/" class="tag-cloud-link tag-link-18 tag-link-position-10" style="font-size: 9.1951219512195pt;" aria-label="depannage (12 éléments)">depannage</a>
<a href="https://blog.seboss666.info/tag/developpement/" class="tag-cloud-link tag-link-111 tag-link-position-11" style="font-size: 8.6829268292683pt;" aria-label="developpement (11 éléments)">developpement</a>
<a href="https://blog.seboss666.info/tag/dns/" class="tag-cloud-link tag-link-392 tag-link-position-12" style="font-size: 11.756097560976pt;" aria-label="dns (17 éléments)">dns</a>
<a href="https://blog.seboss666.info/tag/docker/" class="tag-cloud-link tag-link-491 tag-link-position-13" style="font-size: 12.439024390244pt;" aria-label="docker (19 éléments)">docker</a>
<a href="https://blog.seboss666.info/tag/evolution/" class="tag-cloud-link tag-link-258 tag-link-position-14" style="font-size: 9.1951219512195pt;" aria-label="evolution (12 éléments)">evolution</a>
<a href="https://blog.seboss666.info/tag/firefox/" class="tag-cloud-link tag-link-139 tag-link-position-15" style="font-size: 15.512195121951pt;" aria-label="Firefox (29 éléments)">Firefox</a>
<a href="https://blog.seboss666.info/tag/futur/" class="tag-cloud-link tag-link-123 tag-link-position-16" style="font-size: 13.463414634146pt;" aria-label="futur (22 éléments)">futur</a>
<a href="https://blog.seboss666.info/tag/git/" class="tag-cloud-link tag-link-110 tag-link-position-17" style="font-size: 13.121951219512pt;" aria-label="git (21 éléments)">git</a>
<a href="https://blog.seboss666.info/tag/google/" class="tag-cloud-link tag-link-147 tag-link-position-18" style="font-size: 8.6829268292683pt;" aria-label="Google (11 éléments)">Google</a>
<a href="https://blog.seboss666.info/tag/internet/" class="tag-cloud-link tag-link-100 tag-link-position-19" style="font-size: 8.6829268292683pt;" aria-label="Internet (11 éléments)">Internet</a>
<a href="https://blog.seboss666.info/tag/linux/" class="tag-cloud-link tag-link-29 tag-link-position-20" style="font-size: 22pt;" aria-label="linux (72 éléments)">linux</a>
<a href="https://blog.seboss666.info/tag/mail/" class="tag-cloud-link tag-link-298 tag-link-position-21" style="font-size: 11.243902439024pt;" aria-label="mail (16 éléments)">mail</a>
<a href="https://blog.seboss666.info/tag/manjaro/" class="tag-cloud-link tag-link-113 tag-link-position-22" style="font-size: 10.390243902439pt;" aria-label="Manjaro (14 éléments)">Manjaro</a>
<a href="https://blog.seboss666.info/tag/mariadb/" class="tag-cloud-link tag-link-7 tag-link-position-23" style="font-size: 9.1951219512195pt;" aria-label="mariadb (12 éléments)">mariadb</a>
<a href="https://blog.seboss666.info/tag/materiel/" class="tag-cloud-link tag-link-98 tag-link-position-24" style="font-size: 10.731707317073pt;" aria-label="matériel (15 éléments)">matériel</a>
<a href="https://blog.seboss666.info/tag/migration/" class="tag-cloud-link tag-link-8 tag-link-position-25" style="font-size: 12.09756097561pt;" aria-label="migration (18 éléments)">migration</a>
<a href="https://blog.seboss666.info/tag/mysql/" class="tag-cloud-link tag-link-6 tag-link-position-26" style="font-size: 14.317073170732pt;" aria-label="mysql (25 éléments)">mysql</a>
<a href="https://blog.seboss666.info/tag/nginx/" class="tag-cloud-link tag-link-254 tag-link-position-27" style="font-size: 10.731707317073pt;" aria-label="nginx (15 éléments)">nginx</a>
<a href="https://blog.seboss666.info/tag/opensource/" class="tag-cloud-link tag-link-31 tag-link-position-28" style="font-size: 11.756097560976pt;" aria-label="opensource (17 éléments)">opensource</a>
<a href="https://blog.seboss666.info/tag/partage/" class="tag-cloud-link tag-link-47 tag-link-position-29" style="font-size: 13.121951219512pt;" aria-label="partage (21 éléments)">partage</a>
<a href="https://blog.seboss666.info/tag/performances/" class="tag-cloud-link tag-link-344 tag-link-position-30" style="font-size: 9.1951219512195pt;" aria-label="performances (12 éléments)">performances</a>
<a href="https://blog.seboss666.info/tag/php/" class="tag-cloud-link tag-link-235 tag-link-position-31" style="font-size: 10.731707317073pt;" aria-label="php (15 éléments)">php</a>
<a href="https://blog.seboss666.info/tag/python/" class="tag-cloud-link tag-link-221 tag-link-position-32" style="font-size: 10.390243902439pt;" aria-label="python (14 éléments)">python</a>
<a href="https://blog.seboss666.info/tag/qualite/" class="tag-cloud-link tag-link-640 tag-link-position-33" style="font-size: 8.6829268292683pt;" aria-label="qualité (11 éléments)">qualité</a>
<a href="https://blog.seboss666.info/tag/reseau/" class="tag-cloud-link tag-link-95 tag-link-position-34" style="font-size: 12.439024390244pt;" aria-label="réseau (19 éléments)">réseau</a>
<a href="https://blog.seboss666.info/tag/ssh/" class="tag-cloud-link tag-link-90 tag-link-position-35" style="font-size: 14.317073170732pt;" aria-label="ssh (25 éléments)">ssh</a>
<a href="https://blog.seboss666.info/tag/stockage/" class="tag-cloud-link tag-link-303 tag-link-position-36" style="font-size: 8pt;" aria-label="stockage (10 éléments)">stockage</a>
<a href="https://blog.seboss666.info/tag/securite/" class="tag-cloud-link tag-link-23 tag-link-position-37" style="font-size: 20.80487804878pt;" aria-label="sécurité (61 éléments)">sécurité</a>
<a href="https://blog.seboss666.info/tag/tracking/" class="tag-cloud-link tag-link-46 tag-link-position-38" style="font-size: 8pt;" aria-label="tracking (10 éléments)">tracking</a>
<a href="https://blog.seboss666.info/tag/video/" class="tag-cloud-link tag-link-138 tag-link-position-39" style="font-size: 12.09756097561pt;" aria-label="vidéo (18 éléments)">vidéo</a>
<a href="https://blog.seboss666.info/tag/vie-privee/" class="tag-cloud-link tag-link-75 tag-link-position-40" style="font-size: 14.317073170732pt;" aria-label="vie privée (25 éléments)">vie privée</a>
<a href="https://blog.seboss666.info/tag/virtualisation/" class="tag-cloud-link tag-link-63 tag-link-position-41" style="font-size: 8.6829268292683pt;" aria-label="virtualisation (11 éléments)">virtualisation</a>
<a href="https://blog.seboss666.info/tag/web/" class="tag-cloud-link tag-link-938 tag-link-position-42" style="font-size: 8.6829268292683pt;" aria-label="Web (11 éléments)">Web</a>
<a href="https://blog.seboss666.info/tag/windows/" class="tag-cloud-link tag-link-28 tag-link-position-43" style="font-size: 17.90243902439pt;" aria-label="windows (41 éléments)">windows</a>
<a href="https://blog.seboss666.info/tag/wordpress/" class="tag-cloud-link tag-link-67 tag-link-position-44" style="font-size: 16.024390243902pt;" aria-label="wordpress (31 éléments)">wordpress</a>
<a href="https://blog.seboss666.info/tag/youtube/" class="tag-cloud-link tag-link-71 tag-link-position-45" style="font-size: 10.731707317073pt;" aria-label="youtube (15 éléments)">youtube</a></div>
</aside>
	</section>
	</div>
	
	
	<div id="footer-bg">
	
				
		<div id="footer-wrap">
		
			<footer id="footer" class="container clearfix" role="contentinfo">
				
				<span id="footer-text"></span>
				
				<div id="credit-link">Propulsé par <a href="http://wordpress.org" title="WordPress">WordPress</a> et <a href="https://themezee.com/themes/momentous/" title="Momentous WordPress Theme">Momentous</a>.</div>
			
			</footer>
		
		</div>

	</div>
	
</div><!-- end #wrapper -->

<div id="wtr-comments-end" class="at-footer"></div><a id='wpdUserContentInfoAnchor' style='display:none;' rel='#wpdUserContentInfo' data-wpd-lity>wpDiscuz</a><div id='wpdUserContentInfo' style='overflow:auto;background:#FDFDF6;padding:20px;width:600px;max-width:100%;border-radius:6px;' class='lity-hide'></div>
<!-- Matomo -->
<script type="text/javascript">
  var _paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="https://analytics.seboss666.info/";
    _paq.push(['setTrackerUrl', u+'seb.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'seb.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<!-- End Matomo Code -->

<noscript><p><img src="https://analytics.seboss666.info/seb.php?idsite=1" style="border:0;" alt="" /></p></noscript>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/blog.seboss666.info\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-content/plugins/contact-form-7/includes/js/scripts.js' defer '></script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-content/plugins/worth-the-read/js/wtr.js' defer '></script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-content/plugins/wpdiscuz/assets/third-party/wpdccjs/wpdcc.js' defer '></script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js' defer '></script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-includes/js/jquery/jquery.form.min.js' defer '></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpdiscuzAjaxObj = {"url":"https:\/\/blog.seboss666.info\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/blog.seboss666.info\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","wpdiscuz_options":{"wc_hide_replies_text":"Masquer les r\u00e9ponses","wc_show_replies_text":"Voir les r\u00e9ponses","wc_msg_required_fields":"Veuillez remplir les champs obligatoires","wc_invalid_field":"Une partie du champ est invalide","wc_error_empty_text":"Merci de compl\u00e9ter ce champ pour commenter","wc_error_url_text":"URL invalide","wc_error_email_text":"Adresse email invalide","wc_invalid_captcha":"Code Captcha invalide","wc_login_to_vote":"Vous devez \u00eatre connect\u00e9 pour voter","wc_deny_voting_from_same_ip":"Vous n\u2019\u00eates pas autoris\u00e9 \u00e0 voter pour ce commentaire","wc_self_vote":"Vous ne pouvez pas voter pour vos propres commentaires","wc_vote_only_one_time":"Vous avez d\u00e9j\u00e0 vot\u00e9 pour ce commentaire","wc_voting_error":"Erreur sur vote","wc_held_for_moderate":"Commentaire en attente de mod\u00e9ration","wc_comment_edit_not_possible":"D\u00e9sol\u00e9, il n\u2019est plus possible d\u2019\u00e9diter ce commentaire","wc_comment_not_updated":"D\u00e9sol\u00e9, le commentaire n\u2019a pas \u00e9t\u00e9 mis \u00e0 jour","wc_comment_not_edited":"Vous n\u2019avez fait aucune modification","wc_new_comment_button_text":"nouveau commentaire","wc_new_comments_button_text":"nouveaux commentaires","wc_new_reply_button_text":"nouvelle r\u00e9ponse \u00e0 votre commentaire","wc_new_replies_button_text":"nouvelles r\u00e9ponses \u00e0 vos commentaires","wc_msg_input_min_length":"L\u2019entr\u00e9e est trop courte","wc_msg_input_max_length":"L\u2019entr\u00e9e est trop longue","wc_follow_user":"Suivre cet utilisateur","wc_unfollow_user":"Ne plus suivre cet utilisateur","wc_follow_success":"Vous avez commenc\u00e9 \u00e0 suivre cet auteur de commentaires","wc_follow_canceled":"Vous avez cess\u00e9 de suivre cet auteur de commentaire.","wc_follow_email_confirm":"Veuillez v\u00e9rifier vos e-mail et confirmer la demande de l\u2019utilisateur.","wc_follow_email_confirm_fail":"D\u00e9sol\u00e9, nous n\u2019avons pas pu envoyer l\u2019e-mail de confirmation.","wc_follow_login_to_follow":"Veuillez vous connecter pour suivre les utilisateurs.","wc_follow_impossible":"Nous sommes d\u00e9sol\u00e9s, mais vous ne pouvez pas suivre cet utilisateur.","wc_follow_not_added":"Le suivi a \u00e9chou\u00e9. Veuillez r\u00e9essayer plus tard.","is_user_logged_in":false,"commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"30","liveUpdateGuests":"1","wc_comment_bg_color":"#FEFEFE","wc_reply_bg_color":"#F8F8F8","wpdiscuzCommentsOrder":"asc","wpdiscuzCommentOrderBy":"comment_date_gmt","commentsVoteOrder":false,"wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"","commentTextMaxLength":null,"storeCommenterData":100000,"isCaptchaInSession":true,"isGoodbyeCaptchaActive":false,"socialLoginAgreementCheckbox":0,"enableFbLogin":0,"enableFbShare":0,"facebookAppID":"","facebookUseOAuth2":0,"enableGoogleLogin":0,"googleAppID":"","cookiehash":"1b3fa07f3aa078719fb3f58fd3c82cf5","isLoadOnlyParentComments":0,"ahk":"=6zams2i9gw34m(#av#y4t=zwlt(!lo1","enableDropAnimation":0,"isNativeAjaxEnabled":1,"cookieCommentsSorting":"wpdiscuz_comments_sorting","enableLastVisitCookie":0,"version":"5.3.5","wc_post_id":2935,"loadLastCommentId":0,"lastVisitKey":"wpdiscuz_last_visit","isCookiesEnabled":true,"wc_captcha_show_for_guest":"1","wc_captcha_show_for_members":"0","is_email_field_required":"1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.js' defer '></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpdiscuzUCObj = {"msgConfirmDeleteComment":"\u00cates-vous s\u00fbr de vouloir supprimer ce commentaire\u00a0?","msgConfirmCancelSubscription":"\u00cates-vous s\u00fbr de vouloir annuler cet abonnement\u00a0?","msgConfirmCancelFollow":"Confirmez-vous vouloir annuler ce suivi\u00a0?"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-user-content.js' defer '></script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-content/plugins/wpdiscuz/assets/third-party/lity/lity.js' defer '></script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-includes/js/comment-reply.min.js' defer '></script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-content/plugins/wp-jquery-lightbox/jquery.touchwipe.min.js' defer '></script>
<script type='text/javascript'>
/* <![CDATA[ */
var JQLBSettings = {"showTitle":"0","showCaption":"0","showNumbers":"0","fitToScreen":"1","resizeSpeed":"400","showDownload":"0","navbarOnTop":"0","marginSize":"0","slideshowSpeed":"4000","prevLinkTitle":"Image pr\u00e9c\u00e9dente","nextLinkTitle":"Image suivante","closeTitle":"fermer la galerie","image":"Image ","of":" sur ","download":"T\u00e9l\u00e9charger","pause":"(mettre en pause le diaporama)","play":"(lire le diaporama)"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-content/plugins/wp-jquery-lightbox/jquery.lightbox.min.js' defer '></script>
<script type='text/javascript' src='https://blog.seboss666.info/wp-includes/js/wp-embed.min.js' defer '></script>
</body>
</html>
